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I. ONLINE ASSESSMENT PLATFORM
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1. Adding users
Manual account creation
Manual authentication is enabled by default in the platform.

Manual Login Plugin Location (path): Site Administration > Plugins > Authentication > 
Manage authentication

An administrator or manager can manually create new user accounts in the: Site 
administration > Users > Accounts > Add a new user
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General Section

Username

The user will use this username to log into the platform. It must be unique.

Authentication method
The setting specifies how the e-Learning platform will verify that the password specified 
by the user is correct. Accounts created by an administrator use the Manual Accounts 
method, and accounts that users have created using the email self-registration method 
use the E-mail based self-registration method.

Suspended account
Suspended user accounts cannot log in or use platform services.

Generate password and notify user
The platform will generate a temporary password and send an email to the user with 
instructions on logging in and changing it.

Password
This is the user’s password. A user can change his password through the menu: User menu 
> Preferences.

First Name

Surname

Email address
Password reset notifications, forum notifications and other messages are sent to this 
platform email address. Duplicate email addresses are not allowed on the platform by 
default. This setting can be changed if “Allow accounts with the same email” is activated 
in Site administration > Plugins > Authentication > Manage authentication. This may lead 
to security or privacy issues, for example the changed password confirmation email.

Email display
This setting controls who can see the user’s email address.

City/town 
Country
Timezone 
Language
Description 
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Self-registration via email
This plugin allows users to create their own accounts via the “Create new account” button 
on the platform login page.

Enabling email auto-registration plugin
1.	 In Site administration > Plugins > Authentication > Manage authentication select the 

eye icon next to the self-registration plugin

2.	 Select “Email-based self-registration” from the “Self registration” drop-down menu 
in the “Common settings” section (at the bottom of the page, after the table of 
authentication plugins)

3.	 Save the changes.

Warning: Enabling self-registration may allow spammers to create accounts on the 
platform to use forums, blog posts, etc. for spam. This risk can be reduced by limiting 
self-registration to certain email domains by setting those email domains allowed in the 
Site administration > Plugins > Authentication > Manage authentication section. Self-
registration may also be enabled for a short period of time to allow users to create their 
accounts, and then disabled afterwards.

Tips:
•	 Regularly check the user list for suspicious names and emails and/or users in the 

system who are not enrolled in courses.

•	 Potential users may not receive the account confirmation email due to the fact that it 
ended up in the spam folder, or was rejected by the email server, or the email address 
entered is invalid, etc. These accounts can be manually confirmed by an administrator.

2. User management
Deleting an account
An account can be deleted by clicking the delete icon next to the user’s name.

Attention: Deleting an account results in the permanent deletion of user data. If you want 
to keep the data, it is recommended to suspend the user account instead.
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Account suspension
An administrator can suspend an account by selecting the eye icon next to that user’s 
account in the user list. The administrator can also suspend an account by checking the 
“Suspended account” option in the “Edit profile” page of that account.

The administrator can also select “No Login” from the “Choose an authentication method 
setting” drop-down menu, also from the user’s profile page. Different users must have 
unique email addresses in their profile, even when email is not enabled. When using the 
“No Login” setting, the account email cannot be reused to create another account.

Bulk users’ actions
To perform bulk actions on the user go to Site administration > Users > Accounts > Bulk 
user actions. Administrators can select users by creating a filter and then do any of the 
following:

•	 To confirm accounts created by self-registration based on email, which have not been 
confirmed by the user.

•	 To send a message

•	 To delete accounts

•	 To display the list of those users on a page

•	 Download user data to a file
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•	 Force users to change their passwords

•	 Add users to a cohort

Other bulk actions
1.	 If you know them, choose the users from the available list or click on “Show more” to 

see more filtering options.

2.	 Users can be filtered by name, surname, email address, city, last login, username, 
registration type.

3.	 Select users from the list.

4.	 Choose a filter from the drop-down menu.

5.	 Click the “Add filter” button.

6.	 Select from the left box those users you need and move them to the right box.

7.	 From the “With selected users...” drop-down menu, choose the action you want to 
perform, then click “Go”.
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User Cohort
About Cohorts
Cohorts are site-level or course category-level groups. The purpose of cohorts is to allow 
all cohort members to be easily enrolled in a course. This can be done using ‘Cohort sync’ 
which, as the name suggests, synchronizes cohort membership with course enrolment. 
Alternatively, a cohort can still be manually enrolled in a course.

Creating a cohort
1.	 Cohorts can be created by platform administrators. Click on: Site administration > 

Users > Accounts > Cohorts
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2.	 Select the “Add new cohort” tab

3.	 Note that in the displayed list, you can choose between making the cohort 
available at the site “system” level or at a specific course category level.

4.	 By default, cohorts are visible to users with the teacher role, but turning “Visible” 
off means they are not available for teachers to use in their courses.

5.	 Fill in the details and save the changes.

6.	 Select the ‘Assign’ link next to the cohort name from the list of available cohorts.

7.	 Select potential users from the displayed list, then click the “Add” button.

Adding users to a mass cohort
1.	 Go to “Site administration > Users > Accounts > Bulk user actions”.

2.	 Find users by setting a filter.

3.	 Add users from the available list to the selected list.

4.	 Select “Add to cohort” with the desired users.
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Searching for cohorts
When a platform has a large number of cohorts, keywords can be entered in the “Search 
cohort” boxto search or filter available cohorts.

Category level cohorts
Cohorts that have been created at the course category level can be located by selecting 
the appropriate category and then clicking on the “Cohorts” link in the Actions Menu > 
Cohorts.

You can also access the page Site administration > Courses > Manage courses and categories 
and select Action Menu > Cohorts, next to the respective category.

Enrolling a cohort in a course
There are two ways to enroll a cohort in a course.

1.	 Cohort sync

2.	 Manual cohort enrollment

Using Cohort sync, if users are later added or removed from the cohort, they are 
automatically enrolled or removed from the course.
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Manual cohort enrollment is a one-time action. Subsequent addition or removal of cohort 
users has no effect on course enrollment.

Manual enrollment of a cohort

To manually enroll all members of a cohort in a course:

1.	 Go to the Participants section of a course

2.	 Click on the “Enroll users” button and then select a cohort from the menu with 
available cohorts.

3.	 Select the “Enroll selected users and cohorts” button

3. Roles and permissions
A role is a collection of defined system-wide permissions that you can assign to specific 
users in specific contexts. The combination of roles and context defines a specific user’s 
ability to do something on any page. The most common examples are the roles of learner 
and teacher in the context of a course.

Standard roles
Website administrator
Platform administrators have full rights in the platform.

Users can be assigned the platform administrator role by another administrator in: Site 
administration > Users > Permissions > Site administrators but the role itself cannot be 
edited (or deleted!).

It is not recommended to have many admins on your platform. A good practice is to 
have only one or two, and assign the other users the Manager role with the necessary 
permissions.
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Manager
The Manager role by default allows users assigned this role to access and modify courses, 
as well as perform certain administrative-level tasks related to courses, users, grade 
settings, etc.

Unlike the Administrator role, the Manager role is a role, whose permissions you can 
edit, but which is similar to Site Administrator (but much safer to use) due to its multiple 
default permissions.

Good practices for using the platform recommend assigning administrators the role of 
Manager rather than Site administrator.

Therefore, the Manager role allows a platform administrator to grant multiple rights on 
the platform to others who are assigned a Manager role, but without having to grant them 
full permissions on the platform.

Assigning the Platform Manager role
You can assign someone the Manager role in the platform (to allow them, for example, to 
add new users) by going to Site Administration > Users > Permissions > Assign system roles 
selecting the Manager role and selecting the chosen user.

When you do this, users in this role will only have access to some of the items in Site 
administration. They do not have access to areas such as Security, Server, Plugins, 
Appearance, or Advanced Features, which are accessible only to the group of users with 
the role of Site administrator. They instead have access to most settings and tools for 
managing users, courses and grades.

A user with the Manager role has the ability to assign other users the Manager role at the 
platform level. It also allows me to edit the permissions of the Manager role.
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Assigning the Manager role at Category level

The Manager role can also be assigned at the category level rather than at the platform 
level.

Do this if you want a user to be able to access and manage all courses in a single category, 
but you don’t want them to have access to any of the Site administration tools.

Go to: Site administration > Courses > Manage courses and categories > select a category 
> Actions menu > Assign roles > Manager > select a user > Add

A category-level Manager has rights only on the assigned category; to manage multiple 
categories, you will need to assign them the respective role in each category separately.

Users with the Category Manager role also have the right to manage any subcategory 
within that category, including the ability to create new subcategories and move courses 
within that subcategory.

They also have permission to create new courses in the assigned category.

Course creator
A user with the Course Creator role has the right (as the name suggests) to create courses. If 
the “Creators’ role in new courses” setting in the Site administration > Users > Permissions 
> User policies section is left at the default “Teacher” mode, then the course creator is 
enrolled as a teacher in the course he just created and can edit course settings and sign 
up other users.

A user with the role of Course creator can also see hidden courses.

If a user is assigned a Course creator role at the course category level, the add new course 
button is only visible if that category contains at least one course.

Users with the Course Creator role are not automatically assigned the Teacher role in a 
course they did not create, even if that course is in the category they were assigned to.

Role assignment
A user can be assigned the role of Course creator at system level (in Site administration > 
Users > Permissions > Assign system roles) or at category level.

Teacher
Users with the Teacher role have almost full rights in a course, including adding or 
modifying activities and grading students. By default, teachers can assign Non-editing 
teacher or Student roles to other users.

By default, users are not assigned the Teacher role at the platform level, but on a course-
by-course basis. The same rule applies to learners. Teachers are only allowed to teach the 
courses in which they have been enrolled.



18 FAST

Assigning the Teacher role to a user in a course
1.	 As a Manager or Site administrator, go to the “Participants” page within the course

2.	 Select the “Enroll users” button

3.	 Search for the desired user and select the Teacher role

4.	 Select the “Enroll selected users and cohorts” button

Assigning the Teacher role at the category level
As shown above, by default users are not assigned the Teacher role at the platform level. 
However, under certain conditions, you may want to assign a user or group of users the 
role of Teacher to all courses in a category, or to all courses in the platform, without having 
to enroll the user(s) each time course in turn. So you can grant this permission by editing 
the Teacher role (it’s more recommended to create a new role for this though). Go to 
Users > Permissions > Define roles > Select the Edit icon next to the Teacher role > Context 
types where this role may be assigned. Checking the box for “Category” allows a user to 
access all courses in a category. To assign a teacher to a category, navigate to that category, 
and use the Actions menu > Assign roles. In order for the Teacher role to be assigned to all 
categories, you must navigate to each category and repeat the previous operation.

If you want to give these rights to a limited group of teachers, you can create a new teacher 
role with these permissions enabled and assign them to only those teachers you want to 
assign them to.

Non-editing teacher
A user with the Non-editing teacher role has the ability to view and grade student activity, 
but cannot modify or delete any of the activities or resources.

In courses where groups of learners are used, the user with the Non-editing teacher 
role can be responsible for a certain group and will not have access to other groups. To 
make this possible, change this role’s permissions at the platform or course level so that 
it is blocked from accessing groups it is not responsible for. (Site administration > Users > 
Permissions > Define roles > Select the Edit icon next to the Non-editing teacher role > Look 
for moodle/site:accessallgroups in the permissions table > Uncheck Allow).

Student
A user with the Student role in the platform can participate in the activities of a course and 
view the resources of that course, but cannot modify them or see the class catalog. He can 
see his own grades if a teacher gives him this permission.

Administrators or teachers determine how a learner enrolls in a course and what they 
can see and do in the platform. These permissions may vary for each course or activity. 
For example, in one context learners can correct and grade the work of other learners, 
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be encouraged to explore everything in a course and interact with other participants. In a 
different context, the learner can be guided along a very well-defined path with minimal 
interactions with others.

Guest
Visitors can log in as a Guest using the “Login as a guest” button on the login page and 
access any course that allows guest access. In addition, users who have accounts created 
on the platform, can access any course that allows access to visitors without being obliged 
to enroll in that course.

Visitors ALWAYS have “read-only” access - meaning they cannot leave any messages.

They cannot:

•	 Post on forums

•	 Edit wiki pages

•	 Participate in a chat

•	 Take tests or quizzes

•	 Submit papers

•	 Add comments or data to Glossary or Database activities

•	 Get grades

Visitor access settings
To enable Guest users on the platform:

•	 In Site administration > Plugins > Enrolments > Manage enrollment plugins, make sure 
“Guest access” is enabled.

•	 In Site administration > Plugins > Authentication > Manage authentication, set “Guest 
login button” to “Show” if you want the button to appear on the login page.

•	 Visitors’ actions on the platform can also be recorded: Site administration > Plugins > 
Logging > Log guest access.

Authenticated user
When a user logs into the platform, they are automatically assigned the role of 
Authenticated user. A user will have additional roles in addition to Authenticated user 
depending on where they are in the platform, such as learner in a course.

By default, logged in users are allowed to edit their own profile, send messages, blog, and 
do other things outside of classes.
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Assignment of roles
Context and roles
Apart from the role of manager and course creator, users do not normally have a site (or 
system) level role.

Even though offline you might be a teacher, when you are in the e-Learning platform, you 
might have a teacher role in the course you are teaching and a learner role in another 
course where you are studying for a degree.

Due to the way the platform works, role allocation is done for a specific context. A site and 
a course are examples of two different contexts.

System-level context
•	 To assign a role in context at the system level, go to Site administration > Users > 

Permissions > Assign system roles.

•	 Any roles assigned here apply site-wide. Therefore, it makes sense to assign only roles 
that need this functionality here. The manager and course creator roles are examples 
of two such roles. Assigning a teacher or learner role here would lead to the ability to 
teach / study in every course on the platform, which is not usually desirable.

Front page level context
•	 Front Page settings > Users > Permissions > Assigned roles

•	 Users who have a role in the system-level context no longer need to be assigned a role 
here as well.

•	 If you want to give a teacher rights to manage articles on the Front page, then you can 
assign him the role in the Front page.

Course Category Level Context
•	 Users can be enrolled in a category to save their enrollment in each individual course 

in that category.

Course-level Context
•	 Go to the Participants page

•	 Click on the “Enrol users” button and select the users you want to enroll.

•	 Select the role you want to assign.

•	 Select “Enrol selected users and cohorts”.

Block-level Context
•	 Actions menu (corresponding to the block) > Permissions
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•	 You can assign roles to a block if, for example, you want certain people to see the block 
while it is hidden from others.

Activity-level Context
•	 Access the activity > Actions menu > Locally assigned roles

•	 An example of this would be assigning a learner the local teacher role in an individual 
activity, such as a forum, so that they can moderate their classmates’ posts, while still 
retaining the learner role for the rest of the course.

User-level context
The user-level context is used for roles such as mentor, team leader, or parent. The role 
to be assigned must have “User” checked as the context type where it is to be assigned.

To assign a user the mentor role of another user, click on the user’s profile, then on 
“Preferences”, and then on “Assign roles relative to this user”. If a mentor has a lot of users 
to take care of, it can be assigned to all of them at once, as follows:

1.	 Put all users to be mentored into a cohort.

2.	 Go to “Site administration > Users > Permissions > Assign user roles to cohort” page.

Hierarchy
By assigning a role to a user in a given context, you grant them the permissions contained 
in that role for the current context and all child contexts.

The list of contexts in hierarchical order is as follows:

•	 System (no parent)

•	 Front page (parent: System)

•	 Course category (parent: Parent Category or System)

•	 Course (parent: Category or System)

•	 Modules (parent: Course or System)

•	 Block (parent: Course or System)

•	 User (parent: System)

Roles can be inherited. For example, if a user is assigned a teacher role in a specific course 
category, the user will have that role in ALL courses in the category.

Roles will only work if the role assignment is done in the correct context. For example: 
a teacher role should be assigned to a user in the context of course category or in the 
context of a single course, a forum moderator role for a specific forum should be assigned 
in that specific forum.
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Assigning the platform administrator role
To assign the Site administrator role go to: Site administration > Users > Permissions > Site 
administrators. Select the name on the right and move it to the left.

Verifying the roles assigned to a user
To check or verify the roles assigned to a user, go to their profile page, then under the 
heading “Administration”, click on “Preferences”.

In the “Preferences” page, under the “Roles” heading, click on “This user’s role assignments”.

Hidden roles
If you want to give users access to the course, but do not want them to be visible in the 
list of participants, use the “Other users” link in the course administration menu (“Actions 
menu > More… > Users > Other users”). Assigning roles in this way provides course access 
and editing rights based on the permissions set for the assigned role, without that user 
actually being enrolled in that course.

Multiple assignments
A significant part of the role infrastructure is the ability to assign multiple roles to a user (at 
the same time). The permissions of each role are merged to produce a set of permissions. 
For example, a user could have both teacher and learner roles in the same course.

Make sure that if you change a user’s role, you remove them from any other roles as 
necessary.

4. Adding courses
By default a user with the Teacher role cannot add a course. To add a course to the 
platform, the user must have the role of Site Administrator, Manager or Course creator.

To add a new course:

Site administration > Courses > Manage courses and categories
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•	 Select the category you want the course to be in

•	 Select the “New course” button

•	 Enter the course settings and then select “Save and return” or “Save and display”

Deleting a course
Users with the Teacher role cannot delete courses from the platform. Those with the role 
of Site administrator or Manager can. Users with the Course creator role can only delete 
courses created by them, but only within 24 hours of course creation.

To delete 

•	 From Site administration > Courses > Manage courses and categories

•	 Click on the course category and identify the desired course in the right column.

•	 Select the icon for “Delete”.

Course categories
Course categories are used to organize courses for all users in the e-Learning platform. The 
default course category on a new e-Learning platform is ‘Miscellaneous’ (although this can 
be renamed). Courses can all be put in this category. However, users will find it easier to 
find their courses if they are organized into descriptive categories.

By default, the list of courses in a category shows the teachers and summary of each 
course. If the number of courses in a category exceeds 9, then a short list without teachers 
and summary is displayed.

Adding a category
•	 Go to Site administration > Courses > Add a category

•	 Fill in the desired settings and select “Create category”

Alternatively, you can go to Site administration > Courses > Manage courses and categories 
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and select the “Create new category” button.

Editing a category
You can edit the settings of a category from Site administration > Courses > Manage 
courses and categories and selecting the icon for “Edit”.

Adding a subcategory
Site administration > Courses > Manage courses and categories

You can turn one category into a subcategory of another by checking the box to the left of 
its name, then selecting from the drop-down menu “Move selected categories to”.

You can create a new subcategory by clicking on the “Actions menu” icon to the right of 
the category you want to add it to and selecting “Create new subcategory”.

Hiding categories
Categories can be easily hidden or displayed via “Site administration > Courses > Manage 
courses and categories” and selecting the eye icon next to the category you want to hide.

Hidden categories are only visible to site administrators or those with the “View hidden 
courses” permission.

Course settings
General sections 

Course full name
This is the title of the course. It is displayed as a link on the course listings, on the Front 
page, on the Dashboard and in reports.

Short name
This will be used in several places where “Course full name” is too long, such as the 
navigation block.

Course category

Course start date
This setting affects the display of activity logs and data in the weekly format topic.

If you are using the “Weekly” course format, the start date will appear in the first section 
of the course.
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Course end date
The course completion date is used to determine whether a course should be included in 
a user’s course list.

After the completion date, the course is no longer listed in the navigation block and is 
listed as completed in the learner’s list of courses.

Users can still enter the course after the completion date; in other words the date does 
not restrict access.

Calculate the end date from the number of sections
For weekly format courses only, the course completion date can be automatically calculated 
based on the course start date and the number of sections. If course sections (weeks) are 
added or removed, the course date is automatically changed.

Course visibility
With this setting you can completely hide your course. It will not appear in the list of 
courses of users, except for those with the role of Manager, Course creators, Teachers and 
any other user who has the ability to see hidden courses. Even if users try to access the 
course URL directly, they will not be able to access it.

The section of Description
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Course format section

Hidden sections
This option allows you to decide how hidden sections in the course are shown to learners. 
By default, a small area is shown to indicate where the hidden section is, although users 
still cannot see hidden activities and texts.

Course layout
The course setting determines whether the entire course is displayed on one page or split 
across multiple pages.

Appearance section

Show gradebook to students
Here you can decide whether to allow learners to see the link to the notes. If the course 
does not use graded activities, it makes sense to turn this off.

Completion tracking section
Completion tracking must be enabled to use „Activity completion”.

Course completion criteria can also be based on activity completion criteria.

Groups section

Group mode
Here you can define the group mode at the course level via a drop-down menu. The 
selected setting will be the default group mode for all activities defined within that course. 
Setting group mode can affect what users see in the attendee list and who they can interact 
with in activities.

•	 No group - There are no groups, everyone is part of one big community

•	 Separate groups - Each group can see its own group, users from other groups are 
invisible.

•	 Visible groups - Each group works in its own group, but can also see other groups.
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Force
If group mode is “forced” at a course level, then the selected group mode will be applied 
to every activity in that course.

This will override any activity setting that may have a special group setting.

Course format
A course format refers to the layout of a course.

Weekly format
The course is organized week by week, each section having a title with a specific date. The 
platform will create a section for each week of the course.

Tip: If you want all students to work on the same materials at the same time, this would 
be a suitable format.

Topics format
The course is organized into thematic sections to which a teacher can give titles.

Social format
This format is centered around one main forum, the social forum, which appears listed on 
the main page.

When you select the social format, you can specify how many discussions you want to 
display on the course page:
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Activities and resources can be added to a part using the block „Social activities”.

Single activity format
The “Single activity” format has only one section and allows the teacher to add only one 
activity to the course. When the “Single activity” format is selected, a drop-down menu 
appears from which the teacher can choose the activity they want to use.



29

Home page of a course

3– Course section – the section where activities and resources are displayed

5 – Navigation Block

6 – Actions Menu

Course section editing
•	 Turn editing on from Actions Menu > Turn editing on

•	 Click on the pencil icon (1 in the image below) to quickly rename the section

•	 Click on the “Edit” menu (2 in the image below) to edit the description and other 
settings.
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Adding of new course sections
•	 Turn editing on from Actions Menu > Turn editing on

•	 Click on “Add topics/weeks” in the bottom section

•	 Select the number of additional sections you want and select “Add topics/weeks”

Deleting course sections
With editing enabled, click the “Edit” link to the right of the course section you want to 
delete, then from the menu that appears, click “Delete”. Note that all activities in that 
section and their user data will also be deleted. Use “Recycle bin” to restore the deleted 
section if you change your mind.

Blocks
To add a block to your course page:

•	 Turn editing on from Actions Menu > Turn editing on

•	 Select a block from the “Add block” menu

Activities and Resources
To add an activity or resource to your course:

•	 Enable editing from the menu Actions Menu > Turn editing on
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•	 Click on “Add an activity or resource” to open the menu of activities and resources.

•	 Select an activity or resource, then click the “Add” button or simply double-click the 
name of the activity or resource.

Restricted access
The restricted access feature allows teachers to restrict the availability of any activity 
or even a course section based on certain conditions, such as date, grade earned, and 
completion of an activity.

In the settings page of each activity there is a section for restricted access settings: “Restrict 
access”.

In this section select the “Add restriction” button and a menu of options will open.
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The restriction can be based on completion of another activity, date, grade, student group 
or grouping, or even user profile fields.

The “Restriction set” button also allows for more complex criteria that require multiple 
conditions to concatenate.

Timing
Access can be restricted from / until a specific date and time.
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Grade
You can specify a condition for any course grade: the total course grade or a grade from any 
other activity. You can enter either a minimum value (at least a percentage), a maximum 
value (less than the percentage), both, or neither. The activity will only be accessed if the 
learner has a value for the specified grade and falls within any range of specified values. 
You can add multiple grade conditions. In this case, all conditions must be met for the 
activity to appear.

Group
If groups or groupings of learners are used in the course, it is possible to restrict the activity 
to a specific group.

Hiding conditions
If the eye icon is unchecked, then learners who do not meet that part of the condition will 
not see the activity at all.

If the eye icon is checked, then learners who don’t meet that part of the condition will 
see the activity, but it will be marked as inactive and will have information about why they 
can’t access it yet.

All or one of the conditions
Further restrictions can be added by clicking the “Add restriction” button again and it is 
possible to specify that either ALL conditions or ONE of the conditions are required before 
the activity is available.
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Restrict access to a section of the course
It is possible to restrict access to activities and resources in a course section by specifying 
access conditions in the settings for that particular section. Go to Edit > Edit week / topic 
> Restrict access

.
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Hidden / “orphaned” activities
These types of activities are not visible on the course page but can be used by learners.

Enabling functionality
From Site administration > Advanced features, administrators can enable “Allow stealth 
activities” in courses.

Functionality
1.	 Turn on editing from Actions Menu > Turn editing on

2.	 From the Edit menu next to the activity / resource select “Hide”
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3.	 From the same menu “Edit” select “Make available”

4.	 Don’t forget to share the links to these activities for learners to access.

5. Course enrollment
Manual enrollment

Check if you have active manual enrollment in the 
course
In a course go to the “Participants” page and from the “Actions Menu” menu select 
“Enrollment methods”. On the page that opens, make sure “Manual enrollments” has the 
eye icon turned on.
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Changing manual course enrollment settings
An administrator or manager can edit the current manual enrollment method settings, 
and set the default enrollment period and default role by accessing the “Edit” page link 
next to the enrollment method in the section „Manual enrollments”.

It is also possible for students and/or teachers to be notified when their course enrollment 
expires by selecting “Enroller only” or “Enroller and enrolled user” from the “Notify before 
enrollment expires” drop-down menu and a limit of time in “Notification threshold”.

Enrollment of learners
5.	 Go to the “Participants” page of the course

6.	 Select the “Enroll users” button

7.	 Use the “Assign roles” drop-down menu if you want to change the role you are 
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assigning

8.	 Select “Show more” if you want to expand the default opt-in options. Here you 
can change the registration duration

9.	 Search users and selections

10.	 At the end select the “Enroll selected users and cohorts” button

Setting the enrollment period for each student
1.	 Go to the “Participants” page

2.	 Select the icon for “Edit” next to a user

3.	 Edit the data as needed and save the changes “Save changes”

Self-enrollment
Self-enrollment is the method by which users can choose to enroll in a course, either 
immediately by clicking on “Enroll me in this course” or by typing an enrollment key 
provided to them. The self-enrolment plugin must be activated by the site administrator 
in Site administration > Plugins > Enrollments > Manage enrollment plugins and must also 
be added and activated within the course where it is intended to be used: “Participants” 
within of the respective course > Actions Menu > Enrollment methods.
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Adding an enrollment key to a course
If you only want a certain group of users to self-enroll (and not everyone), then you can set 
an enrollment key that you then pass to them to use when they access the self-enrollment 
screen.

Setting an enrollment key 

1. “Participants” from the respective course> Actions Menu > Enrollment methods

2. Select the “Edit” menu next to the self-registration method

1.	 Add your enrollment key in the box provided.
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2.	 Save the changes

Adding a group-level key for course enrollment
If you want users to directly enroll in a course group, you can set a group-level enrollment 
key that you then pass to them to use when they access the self-enrollment screen.

Setting a group-level enrollment key

1.	 Follow the steps above to add a course enrollment key

o	 If you do not set a master enrollment key for the course, then anyone can 
enroll without a key, and users will not be put into groups.

o	 Users in groups do not need to know the main course enrollment key, only the 
group enrollment key.

o	 Users who are not part of a group can use the main course registration key

2.	 Change the “Use group enrollment keys” setting to “Yes”.

3.	 Save the changes, and then go to the “Actions Menu” button from the main page of 
the course >More... > Users > Groups > Create group

4.	 Add a group-level enrollment key. This will be the key used to register for the course.

*The following settings shown below can be modified by accessing the “Edit” link 
next to the self-enrollment method in the Participants > Actions Menu > Enrollment 
methods page.

Canceling the registration of students who were not 
active in the course
Choose the number of days from the drop-down menu “Un-enroll inactive after”

Setting a maximum number of learners per course
Enter the maximum number of students you want in the course in „Max enrolled users”.
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Accepting self-enrolment only for learners who are 
part of a cohort
If you have cohorts configured at the platform level, then you can enable auto-enrollment 
only for specific cohorts by selecting the cohort name from the drop-down menu „Only 
cohort members”. 

Sending a welcome message to new users
Users may receive the following email message when they self-enroll in a course:

„Welcome to {Course name}

If you have not done so already, you should edit your profile page so that we can learn 
more about you: {link to profile page}”

You can set to send a custom message. The following variables can be included in the 
message: 

•	 Course name 

•	 Link to user’s profile page 

•	 User email 

•	 User fullname 
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Cohort sync
Cohort sync is for automatically enrolling members of a cohort into a course. If a user is 
added or removed from that cohort, then they are automatically enrolled or automatically 
unenrolled, respectively. In other words, Cohort sync synchronizes cohort membership 
with course enrollment.

To be able to use it, it must be activated by an administrator in Site administration > Plugins 
> Enrolments > Manage enroll plugins.

Enrolling a cohort in a course
Note: For the “Cohort sync” option to be accessible, at least one Cohort must exist and be 
available either at the site level or at the category level in which the course is located.

1.	 Go to “Participants” within the respective course > Actions Menu > Enrollment methods

2.	 Select “Cohort sync” in the “Add method” drop-down environment

3.	 Select the desired cohort and click on the “Add method” button

By default, teachers can add cohorts to courses, but a manager or administrator can hide 
certain teacher cohorts by unchecking the “Visible” option in the cohort settings or by 
clicking the eye icon in the cohort list.
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When synchronizing a cohort to a course, it is possible to automatically add all cohort 
members to a group. A new group can also be created when the cohort is added.

Visitor access
The “Guest” access functionality allows users with the Guest role to view the content of 
a course.

1.	 Go to “Participants” within the respective course > Actions Menu > Enrollment 
methods

2.	 Activate the “Guest access” method by clicking on the eye-shaped icon next to the 
method, or add it from the “Add method” drop-down menu if you don’t find it in 
the list

3.	 You can set an access password in the method settings page. Go to the “Edit” link 
next to the method.

Note: Visitors cannot access course activities.
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Enrollment in category
The category enrollment plugin allows users to be enrolled in all courses in a category.

1.	 To be able to use the category enrollment method, an administrator needs to 
activate the “Category enrollments” plugin in Site administration > Plugins > 
Enrolments > Manage enrollment plugins.

Careful! Using the category opt-in plugin may cause performance issues. It is 
recommended that you use Cohort sync instead, although this will require a Cohort 
sync method to be added to each course in the category. 

2.	 Select the menu Actions Menu > Assign roles

3.	 The list of possible roles that you can assign will appear. The roles you see here 
are roles that have been assigned in the context of the category and that you can 
assign, i.e. the role has been checked by an administrator, in Site administration > 
Users > Permission > Define roles > Select role > Edit, at field “Context types where 
this role may be assigned” context “Category”.

4.	 To ensure that new users will be automatically enrolled as learners / teachers in all 
new courses created in that category, an administrator must set the appropriate 
permission for the role in question in the section Site administration > Users > 
Permission > Define roles >Select a role> Edit
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6. Resources
A resource is an item that a teacher can use for course support, such as a file or link.

With the “Turn editing on” option in the “Actions Menu” enabled, a teacher can add 
resources by selecting the “Add an activity or resource” button.

Common module settings
In the settings page for many resources and activities, there is a section called “Common 
module settings”.

Availability
The “Availability” setting has up to three possible options (depends on whether “Allow 
stealth activities” is enabled by an administrator in “Site administrator”). 

„Show on course page”
The activity or resource is available to all students (subject to any access restrictions that 
may be set). 

„Hide from students”
The activity or resource is only available to users with permission to view hidden activities. 
(by default, users with the role of Teacher or Non-editing teacher). 

„Make available but not shown on course page”
To simplify the course page. A link to the activity or resource must be provided 
from somewhere else, such as another page resource.

Group mode
Groups are set at the course level.

When in the course settings, the “Group mode” field is activated and the “Force group 
mode” field is set to “No”, the “” field within the activity can be:

„No groups”
There are no groups and all learners submit their individual work in one area. 

„Separate groups”
Learners submit their work and teachers can sort these works by group or view all 
participants. 
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„Visible groups”
All learners submit their work to one zone, but they can choose which group to associate 
their submission with before uploading.

Book
The “Book” resource makes it easy to create multi-page resources with a book-like format.

The “Book” resource allows you to have main chapters and subchapters. The “Book” 
resource is not interactive. However, you can make the “Book” links to various other 
activities in the course, eg quizzes, forums, etc. Multimedia materials can also be included.

Book setting
In the General section, settings such as resource name, description, etc. are added.

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in „Activity completion”.

Appearance
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Chapter formatting 

•	 None – chapter and subchapter titles are not formatted at all, use this setting if 
you want to define special numbering styles.

•	 Numbers – chapters and subchapters are numbered (1, 1.1, 1.2, 2, ...)

•	 Bullets – subchapters are right-aligned and shown with bullet points

•	 Indented – subchapters are aligned to the right

Style of navigation

Choose between image navigation (1) or text link navigation (2) or no navigation „Table of 
contents” (3).

(1) – Image

(2) – Link text

(3) – Table of contents

Custom titles 

If you don’t enable “Custom titles”, the chapter title (the one that appears in the “Table 
of contents”) will appear as a header at the top of the table of contents (1 below). If 
you enable “Custom titles”, you will be able to create a title different from the one that 
appears in the “Table of contents” or it will not show any title (2 below). If you enable 
“Custom titles”, you will need to enter the chapter title as part of the page content.
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Adding chapters and subchapters
Chapter titles appear as links in the “Table of contents” to the right of the table of contents. 
It is recommended to keep the titles short.

To add a chapter:

1.	 Go to the “Book” resource. Select Actions Menu > Turn editing on or the top right 
button with the same name

2.	 Select the “+” icon in the “Table of contents”, next to the chapter after which you 
want to add the new chapter.

You can add subchapters in the same way. A subcategory cannot have other subcategories.

File
The platform provides an easy possibility for a teacher to present his course materials to 
learners, such as Word documents, PDFs or PowerPoint presentations. All types of files can 
be uploaded and accessed through the platform, but the learner must have the correct 
software to open them.
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Files can be added by uploading from an external source, such as a computer or USB drive, 
or by drag-and-drop directly onto the course page. Both options require editing to be 
enabled Actions Menu > Turn editing on.

Note: How learners see the file will depend on the file type and its display settings. For 
example, a loaded PowerPoint presentation will not play as it would on a “Whiteboard” 
even if it is saved as “Show”. Learners will be prompted to download it.

File Resource Setting
In the General section, settings are added such as the name of the resource, the description, 
as well as the file that will be uploaded to the platform.

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

Display

„Automatic”
The platform will choose the most suitable display method. 

„Force download”
The user selects the file, which will be downloaded to their computer. 

„Embed”
The platform will open the file in a separate page, the platform header and footer will be 
displayed on that page, along with the platform blocks, title and description of the file 
type resource (suitable for video files, pdfs, images).

 „Open”
Similar to the “Embed” option, only in this case the file will be opened in a plain browser 
page, without header, footer, blocks or description. 
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„In pop-up”
Similar to the “Open” option, except that the file will be opened in a new, small, separate 
browser window.

 „New window”
Similar to the “In pop-up” option, except that the newly opened window will open in a 
new browser tab.

Folder
A folder resource allows a teacher to display multiple course files together. The files can be 
of different types and can be uploaded all at once, as an archive that is then unzipped, or 
they can be added one by one in an empty folder on the course page.

Platform folders are intended solely for organizing files, and not for other types of 
resources or activities.

Adding a folder in progress
If you already have a file folder created, you can upload it to the platform in two ways:

The first way (possibly faster)
1. Activate Actions Menu > Turn editing on

2. Drag-and-drop the archived folder into the course section

3. Click on the action you want to perform on the folder (in our case “Unzip”) and 
select “Upload”

4. If necessary, you can edit the folder title by clicking on the pencil icon.
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The second way
1. Activate Actions Menu > Turn editing on

2. Select the “Add an activity or resource” link, and from the displayed list select 
“Folder”.

1.	 In the “General” section, configure the folder title and a short description if 
desired.

2.	 In the “Content” section, add the desired folder as an archive.

3.	 To unzip the folder, click on the folder thumbnail and select “Unzip”
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4.	 Click once more on the archived folder thumbnail, and this time select “Delete” to 
delete the original folder.

5.	 Set the display mode of the folder, if you want to restrict access to it or “Common 
module settings”.

6.	 Save the changes

Creating a new folder and uploading files to it
Use this method if you want to create a folder in progress and then upload files 
to it.

1.	 Activate Actions Menu > Turn editing on

2.	 Select the “Add an activity or resource” link, and from the displayed list select “Folder”.

3.	 Add the folder name and/or a description

4.	 Select “Create folder” if you want to create a subfolder

5.	 Upload the desired files

6.	 Set the display mode of the folder, if you want to restrict access to it or “Common 
module settings”.

7.	 Save the changes.

Display folder contents
Select whether you want the folder displayed on a separate page (default) or on the main 
course page with or without subfolders, and how to display the subfolders.

Show download folder button
If this option is enabled, then a button will be displayed so students can download the 
contents of the folder as an archive for offline viewing.

Label
A “Label” resource serves as a spacer in a course page. It can be used to add text, images 
or multimedia content among other resources and activities in different sections of the 
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course. It is a very versatile resource and can help improve the look of a course if used 
judiciously. Banners or various descriptions can be added to the “Label” to distinguish and 
highlight different areas.

On the other hand, excessive use of multimedia content (audio, video) in “Label” can slow 
down the loading of a course page.

Page
A “Page” resource links to a page that displays teacher-created content. The text editor 
allows the page to display multiple types of content, such as plain text, images, audio, 
video, embedded code, or a combination of all of these.

In some cases, it may be preferable to use the “Page” resource instead of uploading a 
word document, especially if the document contains read-only text that should not be 
downloaded.

URL
A “URL” resource allows the addition of a link to a web site or online file in progress. 
Teachers can use the “URL” resource to provide students with web links for research, 
saving the student the time and effort of typing in the address manually. URLs can be 
displayed in various ways - for example, opening in a new window so that a student can 
access and use the link, close it, and easily return to the original course page.

7. Activity
The activities are interactive materials that require the participation of the learners. To add 
an activity to a course, we enter the course, and select Actions Menu > Turn editing on from 
the upper right corner, and from the “Add an activity or resource” menu corresponding 
to a section of the course, we make the desired choice. Fill in the required fields and edit 
the settings conveniently. Later we can always return to these settings to modify them. At 
the end, press the “Save and display” button at the bottom of the page, to see the created 
activity, or “Save and return to course”.

Assignments
The Assignment activity provides a way for learners to submit work to teachers for grading 
and feedback. The work can be written as online text or as uploaded files of any type that 
the teacher’s device can read. Students can submit individual or group work.

Setting „Assignment” activity
In the “General” section, configure the name of the activity, the description, and you can 
upload a file that can be used as an example for students.
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You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

Availability
•	 „Allow submissions from” - This option prevents learners from submitting an 

assignment before the due date, but does not hide the purpose or the instructions or 
materials included.

•	 „Due date” – Submissions are still allowed after this date, but will be marked as late. 

•	 „Cut-off date” – After this date, learners will not be able to submit work and the submit 
button will disappear. 

•	 „Remind me to grade by...” – A date must be entered here for the activity to be 
displayed in the teacher’s Course overview block and in the Calendar. It will only be 
displayed when at least one learner has submitted a paper.

Submission types
Here you can select how students will submit their work.

Note: If “Submission comments” are enabled, students will be able to add a note to their 
teacher when submitting their work.

•	 „Online text” – Learners edit their work directly in the platform using a text editor. 
A word limit may be set for redacted text.

•	 „File submissions” – Learners can upload one or more files of any type that the 
teacher can open.

Feedback types
•	 „Feedback comments” – With this option enabled, raters can leave comments for 

each submission. 

•	 „Feedback files” – This option allows grading users to upload feedback files at 
the time of grading. These files can be student work, notes, feedback files, audio 
feedback. This option enables the “Feedback Files” column in the activity grading 
section (“View all submissions” button). 

•	 „Comment inline” – This option allows a teacher to provide feedback in the form 
of a comment directly on a work submitted as “online text”.

Submission settings
•	 „Require students click submit button” 

o If set to ‘No’ then learners can make changes at any time. (If a teacher 
wants to block the learner’s ability to modify their work, they must access 
“View all submissions”; locate the learner and from the “Edit” column, 
click on the “Edit” link next to that learner and select “Prevent submission 
changes”).
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o If set to ‘Yes’, learners can upload drafts of the paper until they are 
satisfied with the answer and ready to submit. By clicking the submit 
button, he tells the teacher that he has finished writing and that he wants 
his work to be graded. They can no longer edit their work. If he needs to 
change it again, then he needs to ask the teacher to mark the submitted 
work, at draft status again (Teacher access “View all submissions” > locate 
the learner in the list > Edit > Revert the submission to draft).

•	 Attempts reopened-If “Require students click submit button” is enabled, then 
students can submit a paper only once. You can change this here to ‘Manually’ 
and resubmit, or you can set ‘Automatically until pass’’ so learners can resubmit a 
paper until they get a passing grade.

•	 Maximum attempts – Decide how many resubmissions learners are entitled to.

Groups’ submission settings
Allows learners to collaborate on a single assignment. When grading, the teacher can 
choose to give a common grade and feedback for all students in the group or to give 
individual grades and feedback to each member. 

•	 „Require group to make submission” - If enabled, users who are not members of a 
group will not be able to submit work. 

•	 „Require all group members submit” - This setting will only appear if the teacher 
has checked the “Require students click submit button” button. The work will not 
be classified as “submitted” unless all members of the group have contributed. 
After a student submits a contribution, the other members of the group will be 
able to see who has more to submit.

Using „Assignment”
To know how the student sees the topic, we can switch to the student role by accessing 
the “Switch role to...” link in the user menu, located at the top left of the screen.



56 FAST

The teacher can access the “View all submissions” link. You will be taken to a page showing 
a table of all learners who have submitted a paper and their names.

Chat
Chat allows participants to have a synchronous discussion in real time. The teacher must 
first create a chat room, for which he specifies the time when he waits for learners to log 
in. The session can be repeated during the course, or it can take place only once.

Chat setting
Settings such as activity name and description are added to the General section.

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

In the “Chat sessions” section you can set:

•	 the start time of the next session;

•	 how we want the session to be repeated (here we can choose between repeating 
the session daily/weekly at the same time, not repeating it or always keeping the 
room open and not showing the time when the conversations take place);

•	 the period for which we can save a transcript of the messages, under “Save past 
sessions”;

•	 whether all users can view chat logs.
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Using Chat Activity
Learners can access the chat at any time, not just at the set time. They can communicate 
with other learners who are there.

If we follow the “Click here to enter the chat now” link, we will use the regular chat version. 
This presents a text box at the bottom of the window for entering the message, which is 
sent to anyone who is logged into the chat when the Enter key or the “Send” button is 
pressed. The chat window updates periodically, every 5 seconds.

“Use more accessible interface” - The version without frames and JavaScript allows you to 
type your message in a text box and send it when you press the “Submit” button.

If we follow the link “View past chat sessions”, we will be able to see all the chat sessions. 
Each of them can be viewed or deleted.

Choice
The Choice activity allows the teacher to ask students a multiple-choice question and 
collect their responses. It is like a vote cast by them. It can also be used for initial testing 
within a lesson.

Activity Choice setting
In the General section we add the wording of the question and set whether we want to 
display the options horizontally or vertically (usually the answers look better vertically, 
especially if there are many options).

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

In the “Allow choice to be updated” field, select whether to allow the choice to be updated 
(if yes, the student can change his mind, if not, the student decides only once);

If we select “No” in the “Limit the number of responses allowed” field, any number of 
participants can choose any option; if we select “Yes”, the “Limit” field in the options 
below becomes active, allowing us to set the maximum number of participants who can 
choose that answer option.
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Next, enter the answer options that the learners have to choose from in the “Option” 
fields and, possibly, the values in the “Limit” fields. If there are less than 5 answer options, 
we will leave the last fields blank.

If there are more than 5 answer options, we can add as many as we need by pressing the 
“Add 3 field(s) to form” button.

Next we can check in the “Availability” section that we want to specify the period of time 
in which answers to this choice are accepted, then we are allowed to set the initial and 
final moment.

Section of Results
•	 „Publish results” - we determine how we publish the results (we do not publish 

them, we show them to the students immediately after they have answered, we 
show them to the students only after the choice is closed, we always show them 
to the students).

•	 “Privacy of results” - the confidentiality of the results (if we show the names and 
answers of the learners or keep them anonymous);

•	 “Show column for unanswered” - if we show a column for unanswered questions 
(allows learners to see the number of unanswered questions).

Using Choice Activity
The teacher can view the responses given by the learners by following the link at the top 
right of the activity page “View x responses”. A table will open with one column for each 
answer, with the name and picture of the students who chose that option. The result can 
be downloaded in a format chosen by the user by pressing one of the three buttons at the 
bottom of the page.

Database
The Database activity allows users to collaboratively build, display and query a bank of 
articles on a given topic. Articles can contain images, files, numbers, texts, URLs, and more.

Database setting
Settings such as activity name and description are added to the General section.

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

Entries
With “Approval required” the teacher determines whether student entries must be 
approved by someone with an appropriate role before they are visible to all users. This 
way students can be helped to produce quality work by giving them feedback before 
approving their article.
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At “Allow comments on entries” the teacher determines whether to allow comments 
on articles. If so, they will only be seen in single-item-per-page view mode. Comments 
provide feedback to learners and can help them improve their work.

At “Entries required before viewing” the teacher writes how many entries each student 
must create, to be able to see what other users have worked on. Before this number is 
reached, the learner only sees the new article entry page.

Availability
“Available from” and “Available to” we can select when the database can be visible to 
learners.

If we check “Read only from” and “Read only to”, we can select the dates between which 
the database can be consulted, but not edited.

The “Available from/to” settings override the “Read only from/to” settings.

Ratings
The “Ratings” section defines which roles are allowed to rate articles. Roles can be set 
using the Actions Menu > Permissions menu within the activity.

“Aggregate type” defines how the scores are combined to get the final catalog grade. We 
can choose between averaging the scores, considering the number of items scored, the 
minimum, the maximum or the sum of the scores. If we choose “No ratings”, the activity 
will not appear in the catalog.

Using Database
After pressing the “Save and display” button, we are led to the field definition operation, 
to establish the structure of the database and determine the type of information that can 
be entered by the learners.

Fields can have various default types: 

•	 „Checkbox” allows learners to tick one or more checkboxes;

•	 “Dates” allows learners to select the day, month and year from a drop-down list;

•	 “File” allows learners to upload a file from their computer;

•	 “Picture” allows learners to upload an image file;

•	 “Latitude/longitude” allows students to enter a geographic location;

•	 “Menu” allows students to make a choice from a drop-down menu;

•	 “Multimenu” (multiple selection) allows students to make multiple choices in a 
drop-down menu by holding down the Ctrl or Shift key;

•	 “Number” allows students to enter a number;

•	 “Radio button” allows students to select a single option from a list;
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•	 “Text” allows students to enter a text of up to 60 characters;

•	 “Texting” allows students to enter text longer than 60 characters and format it;

•	 “URL” allows students to enter a URL.

When we want to create a field of a database, after choosing the type we must enter its 
name, its description and possibly specify other options (for example the size of an image 
in the individual view and in the list view or the number of lines and of columns of a text 
area).

The created fields appear on the screen in a table. When the field definition operation is 
complete, press the Save button.

The next step is to edit the template for the user interface in “Templates”. Defining the 
fields produces a default template that can later be easily improved.

Templates are HTML pages that contain tags for working with databases. On the left side 
of the screen there is a list of available tags, from where, by double-clicking, we can add 



61

them to the template. At the end of the editing operation, we save the template, or reset 
it if we are not satisfied.

From now on users can add entries using the “Add entry” tab.

After adding items, they can be viewed one below the other on the “View list” tab or one 
by one on the page on the “View single” tab.

Feedback
The “Feedback” activity allows you to create and conduct surveys to collect feedback. 
Unlike the Survey activity, it allows you to write your own questions rather than choosing 
from a list of pre-written questions, and unlike the Quiz activity, you can create unscored 
questions. The feedback activity is ideal for course or teacher evaluations.
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Feedback setting
In the General section, add the name of the activity and the description.

You can enable settings for restricted access in “Restrict access” and settings for activity 
completion in “Activity completion”.

Availability
Here you can choose when users can fill out feedback.

Question and submission settings

•	 „Record User Names” - Choose here whether or not to show the names of users 
completing feedback.

•	 “Allow multiple submissions” - Choose here whether or not to allow users to 
complete feedback multiple times.

•	 “Enable notification of submissions” - If set to “Yes”, teachers will receive 
notifications when users submit feedback.

•	 “Auto-number questions” - If set to “Yes”, then the questions will be numbered 
automatically.

After submission
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„Show analysis page” - Summary results can be displayed to respondents or shown only 
to teachers. „Completion message” - This allows you to present users with a personalized 
message after they answer questions. 

„Link to next activity” - This allows you to add a link to another activity or website that you 
want them to be redirected to once they have answered the questions.

Using Feedback
After setting up a “Feedback” activity, add questions by clicking the “Edit questions” tab 
and selecting the question type from the drop-down menu. Add the details of the question 
and click on “Save question”.

Standard options
The following options apply to the vast majority of question types.

•	 “Position” - This number controls the order of the questions. Position 1 has the 
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question closest to the top of the page, so when you create or edit a question, you 
can choose from the drop-down list of available positions (which will vary depending 
on how many other questions there are). You can also arrange questions by clicking 
the up and down arrows on the main add questions screen.

•	 “Required” - The answer to these questions is mandatory

Captcha
A test to make sure a real person is filling out the form and not an automated spam 
program.

Information
This element allows you to display the course and/or category the feedback is in.

Label
Like a standard tag, this allows you to add text between questions that provides additional 
explanation or breaks the feedback into sections.

Longer Text Answer
This question type is for creating a text box (specify how large it will appear in rows and 
columns) into which users can write a longer answer.

Multiple choice
This question gives you three alternatives:

1.	 “Multiple choice single answer” - Allows setting multiple choice options, with radio 
buttons. The first option can be “Not selected”. Only one option can be chosen.

2.	 “Multiple choice, multiple answers” - Allows the selection of several options.

3.	 “Multiple choice - single answer allowed (drop-down menu)”- WILL display a drop-
down menu from which only one answer can be selected.

Numeric answer
Use this question when you need to get a number as an answer. You can specify the range 
between which the number should be found.

Multiple Choice (Rated)
It is similar to the other multiple choice questions, except that each option has a numerical 
value associated with it. You can choose to use radio buttons or a drop-down menu to 
display the answer options.

Short Text Answer
It gives you the ability to use a question type that requires a single text response, with an 
input box that has a set number of characters.
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Dependence item and Dependence value 
It is possible to direct the user to specific questions based on a previous answer. For 
example, if they answer “Yes” to the question “Do you have a car?”, they will be directed 
to a different question than if they answered “No”. To set dependent questions:

• Set up the initial question and give it a name in the “Label” field

• Add a “Page break”

• Add the question that will be reached if (for example) the user answers “Yes”.

• In “Dependency item”, select the label (“Label”) of the first question.

• In “Dependence value” type the dependent answer (like “Yes” in our example.)
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• Follow the same process for the other answer (such as “No”)

Forum
The forum is a tool for asynchronous discussions. The teacher may require all students 
enrolled in the course to register for a forum; thus they will receive email notifications 
when each new position appears and will be able to communicate with each other and 
with the teacher at any time.

There are five types of forums:

•	 „Standard forum for general use” – The usual type of forum, generally found where 
anyone can initiate a discussion at any time. 
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•	 „Single, simple discussion” – Allows the creation of a single discussion that anyone can 
reply to. 

•	 „Each person posts one discussion” – It allows any learner to post a single discussion, 
to which anyone can reply. 

•	 „Q and A forum” – Require each learner to post their own input before they can see 
others’ contributions 

•	 „Standard forum displayed in a blog-like format” – Anyone can start a discussion at 
any time, and the topics are displayed in the form of a blog.

Forum setting
When we start creating a forum, in the General section we have to specify its name, decide 
what type we want it to be and give a short description of it.

Attachments and word count
At “Maximum attachment size” we specify the maximum size of the file that can be 
attached to a post on the forum.

At “Maximum number of attachments” we specify the maximum number of files that can 
be attached to a post on the forum.

Subscription and tracking
At “Subscription mode” we have to choose a mode of registration to the forum.

The first mode allows participants to choose whether to join the forum. In the second 
mode, participants are automatically enrolled and cannot opt out. In the third mode, 
participants are automatically enrolled at first, but can opt out later. The last mode does 
not allow registration.

“Read tracking” - Can have two values: optional (participants can choose whether or not 
to subscribe when receiving messages) and disabled (subscription is disabled).

Post threshold for blocking
„Time period for blocking” - We specify a duration, from a day to a week, if we want to be 
able to block students, or not to block otherwise.

At “Post threshold for blocking” we specify the maximum number of posts that a learner 
can make in the previously specified time period.

“Post threshold for warning” is how many posts a warning is sent to learners.
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Ratings
In the “Ratings” section we can specify which roles allow the rating operation.

“Aggregate type” determines how the ratings will be combined to get the final catalog 
grade. We choose “No ratings” if the activity will not appear in the catalog.

„Restrict ratings to items with dates in this range” allows us to limit the evaluation of posts 
only to those published in a certain period.

Using Forum
The teacher who created a forum must later manage it. First of all, it is good to inform 
the students how often (daily, weekly, etc.) he will enter the forum and answer their 
messages. They must also establish some rules of behavior regarding the language, the 
topics addressed and others. Learners need to be helped to understand the difference 
between a social forum and an academic forum. The quality of learners’ posts can also be 
influenced by the grades they receive in their assessment. Finally, if the situation gets out 
of hand, the teacher can delete unwanted posts from the forum.

When a thread becomes very long, it can be archived and moved to a forum specifically 
created for this purpose, usually at the beginning or end of the course. For this, choose 
“Move this discussion to...” located on the top right of a discussion thread, then press the 
“Move” button. In place of the moved discussion, you can put a new post with a summary 
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of it.

Another recommended practice is to establish a small group of learner moderators for 
each forum or discussion. These learners need to prepare well to master the subject 
and answer the basic questions. They may be allowed to rate their peers’ posts, archive 
threads, and write summaries for them.

Glossary
The glossary is like a dictionary maintained by the participants. Each discipline has its own 
specialized terms, new words, acronyms, abbreviations. Within any course we can develop 
a set of terms with their definitions, definitions that can be easily accessed through links.

The teacher usually creates a main glossary in the general section at the beginning of the 
course and several secondary glossaries in other sections where needed. The latter can be 
configured to be edited and commented on by learners. Entries from secondary glossaries 
can be imported into the main glossary. If this import is not needed, then we can just 
create secondary glossaries.

Glossary setting
On the page for creating a glossary, in the General section we specify the name and a short 
description.

The global glossary has terms accessible from across the site, not just from one course. 
Therefore only the administrator can create a global glossary.

In “Glossary type” we specify whether we want to create a main glossary or a secondary 
one.
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Entries
At “Approved by default” we decide whether we want entries to require a teacher’s 
approval before they become visible to all participants.

“Always allow editing” specifies whether students can only edit their entries during an 
allotted time, or whether they will be able to do so at any time.

At “Duplicate entries allowed” we specify whether we allow more entries with the same 
name.

At “Allow comments on entries” if we want participants who have permission to post 
comments, to be able to comment on glossary entries.

At “Automatically link glossary entries” we specify whether we want any occurrence of 
glossary terms in the course to have the form of a link to the associated explanation.

Appearance
At “Display format” we choose one of the 7 available display formats.

•	 “Full with author” displays author data and attached files as links.

•	 “Full without author” displays attached files as links.

•	 “Encyclopedia” lists entries one by one, separated only by edit icons.

•	 “Entry list” is like “Full with author”, having in addition the images displayed in the line.

•	 “Simple, dictionary style” does not show authors and attachments appear as links.

•	 “FAQ” has the words “QUESTION” and “ANSWER” appended to the definitions of the 
concepts.

„Show alphabet links” determines whether participants can browse the glossary in 
alphabetical order.

“Show ‘ALL’ link” determines whether all entries can be browsed at once.

“Show ‘Special’ link” specifies whether to browse the glossary for special characters such 
as @ and #.
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“Allow print view” determines whether learners are shown a link (always available 
to instructors) to a printable version of the glossary.

Ratings
In the “Ratings” section we establish, as we presented in the previous activities, 
which are the roles that allow the evaluation of the entries, how the grades are 
aggregated to obtain the final grade in the catalog and if the grading is restricted 
to a certain specified period of time.

Using „Glossary”
When we go to the glossary link on the course page, we are taken to the glossary 
page, where we can add new terms, after pressing the button „Add a new entry”.

On the page for adding a new entry we are asked to write the concept and its definition, the 
associated keywords, to specify whether we want the occurrences of this current concept 
to become links to its definition, if we take into account the type of letters (uppercase and 
small) in the word and if in the course it will signal only the occurrence of the word alone 
or also when it is included in other words.

Glossary entries can be viewed alphabetically, just a specific letter, or all at once.

Lesson
The lesson created by the teacher consists of a number of pages for the learner to go 
through. Generally, at the bottom of each page is a question. Depending on the correctness 
of the answer provided, the learner is led to the next page or returned to a previous page.
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Lesson setting
On the page to add a lesson, in the General section we fill in the name and a short 
description of the lesson.

Appearance
„Display ongoing score” produces the display on each page of the total score 
obtained by the learner up to that point. 

„Maximum numbers of answers” represents the maximum number of answer 
choices that can be found on the lesson pages.

Availability
By enabling “Available from” and “Deadline”, we can specify the calendar dates between 
which the lesson is available.

If we activate “Time limit”, then here we specify how many minutes the students 
must complete the lesson. The learner can exceed this time limit, but late answers 
are no longer taken into account when determining the grade.

Flow control
In the “Flow control” section we can specify:

•	 „Allow student review” – the “Yes” option if we want a button to be present on the last 
page of the course that allows the student to resume the lesson;

•	 „Provide option to try a question again” – “Yes” option for a button to appear after 
giving a wrong answer to a question. The learner can choose to answer again, without 
being scored, or to continue the lesson; 

•	 „Maximum number of attempts” – which is the maximum number of attempts allowed 
for each question. Upon reaching this maximum, the learner will automatically be led 
to the next page;

Grade
•	 At “Practice lesson” we determine if it is just a practice lesson, which is not passed 

into the catalog.

•	 Custom scoring allows each response to be assigned a positive or negative numerical 
value for evaluation purposes.

•	 If Retake-allowed is set to “Yes”, learners will be able to retake the lesson.
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•	 If we allow learners to access the lesson more than once, we define in “Handling of 
re-takes” how we grade them (as an average or as a maximum of all attempts).

Using Lesson
After saving the lesson, it will appear as a link on the course page. Upon accessing the 
newly created link, we are taken to a page to start editing the lesson content. The page 
has 4 tabs: “Preview”, “Edit”, “Reports” and “Grade essays” of which the first two are the 
most used.

The lesson is made up of pages. The student interacts with two types of pages: “Content 
page” and “Question page”. The first type, in addition to other content, can provide links to 
other pages, resembling a table of contents. It has no effect on the grade. The second type 
has title, content and a question at the bottom of the page. Depending on the correctness 
of the answer provided, the student is directed to a new page.
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It is customary for the first answer to be the correct one and the following ones to be 
wrong. As the learner moves through the lesson, these choices appear in a random order. 
Many times when we create a page, we cannot correctly determine which page we want 
to jump to because that page has not been created and saved and thus does not appear in 
the drop-down list to be chosen. In this case, we make another choice, save the page and 
resume editing it after the desired page has been created.

Quiz
The test is a logical unit of activity on the platform, perhaps the most important unit for 
scoring student knowledge objectively.

The test should be seen or understood as a structured unit of items, of the same mode 
of presentation on the screen or of heterogeneous presentation, through which the 
assessment or self-assessment of a volume of knowledge or skills is aimed. From the 
perspective of e-learning platforms, the test is a form that allows easy management of 
application parameters such as the number of items, the way of extracting the items, the 
interactive way or not, the total working time, the frequency of questions, the right to 
return or not on the answers, the application of penalties or not, the amount of penalties 
applied, running the test several times, the minimum time interval between two runs, the 
time of activation, the time of shutdown, etc.

The test is created inside the course to which it belongs. “Turn editing on” is activated via, 
and “Quiz” is chosen from the list of activities.
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Quiz Setting
As a result of this request, the system opens a new window representing the configuration 
form of the future test. Parameters can be set anyway because it allows to return to edit 
mode even after populating the quiz with questions. Restrictions can only come in after 
the test has been run by a group of learners.

In the General section, fill in the name and description of the respective test activity.

Timing
In the “Timing” section, the parameters related to the start date, stop date and duration 
of the test are set. There are also fields for setting the behavior of the test once the time 
limit has expired as well as the field for setting the time limit until a test can be sent. This 
last field is only valid if “When time expires” was set to “There is a grace period...”.

Grade
When it is allowed to solve the test more than once, there are several ways to calculate 
the final grade. Thus, one can choose from the following options: 

•	 „Highest grade” - the attempt with the best grade determines the final grade.

•	 “Average grade” - the final grade is calculated as follows: the grades from all 
attempts are averaged.

•	 “First grade” - the final grade is the one obtained on the first attempt to solve the 
test (the other attempts are ignored).

•	 “Last grade” - the final grade is the one obtained on the last attempt to solve the 
test (the other attempts are ignored).

Question behavior
If “Shuffle within questions” is enabled, then each time the student accesses the multiple-
choice questions and matching questions, their components will be shuffled randomly.

Review options
Section „Review options” represents a set of options for viewing results and feedback.

Extra restrictions on attempts
Section „Extra restrictions on attempts” contains fields to set a password to access the 
test, to restrict the IP address of the device from which the test can be run, fields to set 
the time interval between the first and second attempts, and to set the time intervals 
between subsequent attempts.
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Also, in this section, the option to do recognition can be activated, by confirming the 
Web identity validation field. This facility requests access to capture the user’s image 
through the web camera to identify the candidate who accessed the exam. The app will 
automatically capture the image every 30 seconds and store it as a PNG image. It also 
captures the screenshot during the test to verify that the student has not attempted 
unusual activities during the exam.

Before starting the test, the candidate will be asked for camera permission and screen 
sharing permission. By accepting the permission, he will be able to see the capture in 
real time and will be able to continue answering questions. The system works as a video 
recording service as if everything is captured so that the user does not try to do anything 
suspicious during the exam. Features offered:

•	 Capture user/student images via webcam

•	 The test cannot be accessed if the user does not allow the camera to be turned on

•	 Offer the ability to generate reports and check for any suspicious activity

•	 Will work with existing Question Bank and Quiz

•	 Web service API for external calls
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•	 Images are stored in Moodle data as a small PNG image

•	 Image can be deleted individually or in bulk

•	 Surveillance log report with search facilities

•	 Configurable image size and capture interval

•	 Face Recognition Service (AWS/BS).
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Overall feedback
In the “Overall feedback” section, you can set a text to appear after the test is completed. 
If Grade boundary is filled in, then feedback will be displayed based on the grade obtained.

Using Quiz
Inside the tests, after creating the test by setting the parameters above, in the previous 
form, you can modify parameters, general information about the test, view content, 
student results, edit content, access question categories, access questions, export, import 
etc.

The varied content of the test is ensured mainly by the way the question categories are 
created and the way they are called.

The evaluation of the results can be done by keeping the minimum score, the maximum 
score or the average score.

After the test structure has been created, proceed to completing it with questions by 
activating the “Edit quiz” button.

The next step is populating the test with questions. New questions can be added at that 
time to the test. They will be automatically saved in a category in a database of questions, 
so that they can be used in other tests within that course.

Already existing questions can be selected from the question database, “Question bank”, 
and inserted into the list of questions actually used in the test. A test may include certain 
questions that the teacher explicitly wants to exist and others that the system draws 
randomly from one category or another.

The questions themselves can have the answers in the order in which they were edited or 
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in a random order that changes with each presentation.

In order to make good use of the flexibility of building tests, it is imperative that the 
questions be built by category, structured by chapter and by question type. Organizing 
questions by categories and subcategories is essential when working with large question 
packs because a top-ranking question category can call on questions from all of the 
subcategories it includes for a given test.

Constructing question categories
A category of questions usually belongs to a course. There is the possibility of inheritance 
if they have the public attribute set or if they are attached to a course that is in turn part of 
a Meta course. The way of structuring by categories, respectively subcategories depends 
exclusively on the course administrator. When there are many questions there is a risk 
that, if the questions are not organized very well, the same question will appear in a test 
several times.
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First select the course to which the category will belong, then the “Course administration” 
page opens from the “Actions Menu” > “More...” menu. Here we will select the “Question 
bank” > “Categories” section.

For each course there is a default course category. Beginners in the activity on the platform 
tend to use exclusively this category, a fact that later can have unwanted implications, 
especially in the situation where that block is shared between several teachers. This 
creates the possibility of interference for tests.

We choose the parent category for the category we want to create. If there are many 
categories implemented, we must scroll to the end of the list. Edit the name of the 
category, possibly also edit explanatory information in “Category info”, and then select 
the “Add category” button.

Types of questions

Multiple choice
A set of answers is proposed. By selecting the validation fields one or more answers are 
chosen. Editing the question is similar to the others and the mark allocation for building the 
question is illustrated below. Do not forget that for multiple correct answers the scoring 
is done in such a way that the sum of the scores is the maximum score. This question 
can be set to have only one correct answer. In this case, the correct answer will have the 
maximum score, and the other answer variants 0.
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True / False
For this type of question, you choose by radio button if the statement is true or false.
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Matching
This type of question requires matching correct answers from lists of possible answers. 
Editing the question is as follows:

Short answer
The answer is a short text. It can be capitalized or not as the teacher sees fit, or it can be 
numbers.
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Numerical
This type of question expects a numeric value as an answer. It lends itself very well to 
abstract subjects for quickly checking problems that involve calculations. The correct 
answer can be within a deviation specified by the error entered during editing.
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Essay
For this type of question, the answer is a text that the student edits and the examiner 
notes. The system cannot do evaluation automatically. For evaluation, the teacher must 
intervene to read the answer given by the student and mark it in the classic way. The 
question editing window is as follows:

Calculated
Calculated type questions allow checking the correctness of the calculations performed by 
the test takers individually for one and the same expression. They are particularly useful 
for mathematics, physics, and technologies of various profiles. The proposed solution 
expression can be edited in the question body. After editing the calculated type question, 
the system proposes to each tested person a set of values from the definition field of the 
proposed expression and waits for the tested person to enter the correct answer value.

The operators +, -, *, /, and % are accepted in expressions, the latter being the module 
operator. 24 predefined, single-argument functions are also supported, namely: abs, acos, 
acosh, asin, asinh, atan, atanh, ceil, cos, cosh, deg2rad, exp, expm1, floor, log, log10, 
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log1p, rad2deg , round, sin, sinh, sqrt, tan, tanh, and two two-argument functions: atan2 
and pow. The min and max functions, of two or more arguments, can also be used.

When writing an expression, the Meta characters (literal notations in the expressions) 
will be inserted between curly brackets {}, and for the function argument if a predefined 
function is used, the type of brackets () is used. The expected response value may have 
a deviation from the exact value. The tolerance field allows the questioner to decide the 
margin of error. Depending on the specific situation, the type and value of the tolerance 
must be chosen very carefully.

The tolerance accepted for the result can be of three types: relative, nominal and 
geometric:

•	 relative tolerance - for example 0.25, results with a value between +.- nominal 
value*25% are accepted

•	 nominal tolerance – for example if it is 10, results with a value between: nominal value 
-10 and nominal value +10 are accepted;

•	 geometric tolerance - for example, if it is 0.5, results with a value between the values 
are accepted: the nominal value/(1+0.5) and the nominal value*(1+05).

When editing the question, the system creates tables of associated values for the 
variables included in the edited calculation expression. These tables can be shared with 
other questions or they can be individual. In order not to have unwanted or so to say 
uncontrollable interferences of the definition domains, only the version with its own 
table was used for the questions, for each question and Meta character. Sharing tables of 
values can lead to unexpected but apparently consistent results with the mathematical 
expression.

If several correct answers are assigned in certain situations, then the percentage sum of 
the answers must be 100%.



86 FAST

Drag and drop onto text
A type of question where we drag the mouse from a list, missing words from a paragraph.
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Add the question in the text editor, using whatever formatting you like. Use double square 
brackets “[[n]]” with a number in place of the word you want students to find:

Add the missing words or phrases in the correctly numbered boxes in the ‘Choice’ section. 
(You can add more words to make it harder to choose the right ones.)

Select missing words
It’s very similar to the “Drag and drop onto text” question, but uses drop-down menus 
instead of drag-and-drop boxes.



88 FAST

Scoring the questions and the test
By default a question is scored with a value of 1 point. Obviously the creator of the question 
can assign a different score.

From this value, some questions allocate partial percentages depending on the answer, for 
example the true or false type question 100% or 0%, and others where there are several 
true answers to the question a proportional percentage, with how many correct answers 
the question has and how many answered, percentage calculated from the total value 
given to the question. The sum of positive percentages for each question is mandatory 
100%.

Negative percentages can also be assigned for wrong answers, as this penalizes students 
who fill in answers carelessly and in haste. Leaving wrong answers unscored means 
allowing random completion, such as if I guess right, if I don’t, nothing happens. In 
addition, completing all the validation boxes leads to a low or even zero score.
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Against these points assigned to each question, the test has a default general penalty 
factor of 0.1, which is activated when a student goes back to one or another of the 
answers and makes changes. This penalty factor may discourage those who are unsure of 
completing the answers. This factor can be set to severe de-pointing values depending on 
the concrete application conditions of the test.

At the end of the test, the learner sees what result he obtained.
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Feedback
All question types accept feedback for each answer where the question allows for multiple 
answers or global feedback for the entire question. These will be displayed customized 
correlated with how each learner answered each question. In addition, the entire test 
can have a feedback that will be displayed to everyone who took the test. Feedback and 
results will be displayed at different times decided by the teacher according to the settings 
chosen in the figure below.

Quiz Results
To see the results or reports of a test and whether there are essays that need to be 
manually graded, a teacher can go to the Actions Menu > Results menu within a test.

Wiki
„Wiki” allows the collective creation of documents, keeping a history of all the changes 
made. A wiki can be worked on by the whole class or a single student, assisted by the 
teacher and peers. It starts with a first page, to which students can add others, creating 
links to new pages that do not yet exist. The home page can be designed as a table of 
contents, with links to other pages.

It’s a very fast way to create batch documents. There is usually no one person who has 
editorial control.

Wiki Setting
On the page of creating a “Wiki” we type the name and a short description of it.

We also specify the name of the first page in “First page name”, select in the “Wiki mode” 
field if we want this wiki to be collaborative (everyone can edit it) or individual (it can be 
edited by only one person), the default format (used when editing wiki pages) and if we 
force the format (it is no longer possible to choose the format when editing a wiki page).

Using Wiki
After the save operation, the new wiki becomes the link on the course page. When a user 
accesses the link, he is taken to a page where he sees the description of the wiki activity, 
the name of the initial page, can choose one of three formats and then, by pressing the 
“Create page” button, initiates its creation.
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To create a page we have at our disposal the well-known HTML editor. We can add text, 
tables, images, we can format the text. If we want to add a new page, we first create a link 
to it by writing text enclosed in double square brackets. By pressing the “Save” button, we 
will view the page and see the links created.

If we click on one of the links that just appeared in the view mode, we will again be led to a 
page where the creation of a new page is initiated, which will be associated with that link. 
Its title is the text we enclosed in double square brackets before. We also edit this page 
and press the “Save” button. To return to the initial page when viewing another page, 
press the “Search wikis” button in the upper right corner.

Workshop
The “Workshop” activity is a complex activity, with great pedagogical potential, which 
involves the completion of tasks and a structured framework for evaluation or feedback. 
The teacher specifies several aspects of the task, which are assessed separately and 
then combined to obtain the final grade. Learners don’t just submit assignments, they 
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participate in peer-reviewed assignments, providing feedback, suggestions, and grades. 
This mode of assessment gives learners the opportunity to see other assignments and 
learn from them and feedback from others.

The basic steps in this activity are:

•	 the teacher establishes the work topic, its criteria and the grading strategy;

•	 optionally upload examples of good and bad homework, which students train by 
evaluating them;

•	 students prepare and submit their assignments. They have the option to download 
their theme from the platform, redo it and submit it again;

•	 optionally the students evaluate their topic;

•	 optionally, students receive a set number of randomly chosen topics to appreciate, 
comment on and evaluate. Their grades can be overwritten by the teacher;

•	 optionally the teacher evaluates the assignments and the quality of assessments 
made by the students;

•	 the final grade is determined by combining the grade for the completed topic with the 
grade for the evaluation.

When learners do not assess and there is only one marking strategy, the activity is similar 
to the one called “Assignment”.

If the assignment is to submit an essay and there are a lot of students, the teacher can 
randomly check a few assessments made by them. He will be alerted to papers for which 
there are large differences in grading, in which case he will have to determine the grade 
for the author’s work and the grades for the assessments made by the students himself.

When he wants to get good quality papers, the teacher can do this: in the initial period he 
only allows commenting on the assignments, not marking them. Based on the comments 
received, learners redo their assignments and resubmit them to the same assessors for 
grading. The process can be repeated until the desired quality of work is achieved.
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Workshop Setting
In the General section of the page to add a seminar, we must specify its name and a short 
introduction.

Grading settings
In the “Grading settings” section we can specify:

The evaluation strategy, by the values chosen in the drop-down list „Grading strategy”:

•	 “Accumulative grading”: Each evaluation criterion has its own numerical score and 
o  weighting; a final grade is calculated based on the criteria scores and respective 
weights;

•	 “Comments”: No numerical grade, only feedback, in the form of comments;

•	 “Number of Errors”: Evaluators decide whether or not the paper ticks each criterion 
(eg, has original ideas; answers the question);

•	 “Rubric”: Generates a numerical grade based on the level of achievement chosen by 
the evaluators for each criterion. The maximum grade I can get for the assessments 
made, in „Grade for Assessment”.

Submission settings
In the “Submission settings” section, you can set instructions and requirements for the 
works to be submitted, the maximum number of files that can be uploaded and their size 
limit. Checking “Late submissions” will allow learners to submit a paper after the deadline. 
Any late submission cannot be changed by the learner - they only have one chance to 
submit it.

Assessment settings
In the “Assessment settings” section we can specify some instructions regarding the 
assessment. These instructions are important for learners to better understand how to 
evaluate their peers’ work.

By checking “Use self-assessment” the learner can receive his own homework for 
assessment.
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Example submissions
By checking “Use examples” we provide examples of assignments that will help learners 
better understand what they have to submit and they can practice the assessment on 
these examples. If you provide a paper as an example, you can choose whether learners 
must grade it or whether it is optional. If they are asked to rate sample papers, then 
you can also decide whether they rate them before they submit their own papers, or 
afterwards but before peer assessment.

Using Workshop
After saving, the seminar can be found as a link on the course page. If we follow this link, 
we are led to the seminar page, where we see, apart from the requirement, the stage we 
are at in this activity.

Setup phase
It can be seen that the first two stages have been completed, being ticked, and now we 
have to specify how we want the students to evaluate the assignments of their colleagues. 
For this we follow the “Edit assessment form” link, which leads us to the “Accumulative 
grading” page. Here we can fill in all the criteria that must be taken into account in the 
evaluation, as well as the score and weight given to each one.
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After this step, the “Edit assessment form” step also appears checked. The teacher will 
have to select the “Switch to the next phase” link to start the next phase: “Submission 
phase”.
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Submission phase
The student can now access the “Submit your work” link to submit the work file. It takes 
you to a page that displays the submission instructions, filled in by the teacher during the 
seminar creation stage.

Once a user has submitted a paper, the teacher can access the “Allocate submissions” link 
to determine how users will receive the work of colleges for assessment.
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•	 „Manual Allocation”: Here, a teacher can manually select which students will 
grade whose work. A learner can review work even if they haven’t submitted it 
yet. 

•	 „Random Allocation”

o Number of reviews: Here, the teacher chooses between 0 and 30 evaluations 
for each paper or for each evaluator. That is, the teacher can choose to set the 
number of assessments that each paper must have or the number of assessments 
that each student must perform;

o Prevent reviews by peers from the same group: If the teacher wants members 
from the same group to never review each other’s work;

o Remove current allocations: Checking this option means that all manual 
allocations set in the “Manual Allocation” menu will be removed;

o Can access with no submission: Allows learners to assess the work of other 
learners, even if they have not submitted their own work;

o Add self-assessments: Students must evaluate their own work alongside that of 
their colleagues; 

•	 „Scheduled Allocation”: The platform will automatically (randomly) allocate the 
works that will be evaluated once the deadline for sending the works has passed.

The teacher must select “Switch to the next phase” to proceed to the next phase: 
“Assessment phase”.



98 FAST

Assessment phase
Learners can grade example assignments to practice their assessment, before grading 
their peers’ work, only if this feature is enabled. They can compare their assessments with 
the teacher’s benchmark assessments. A learner will be assigned a certain number of 
assignments from their peers to grade. He will receive a grade for each assessment made, 
which will be added to the grade for his own submitted work and his final grade for this 
activity will be calculated. A student may be assigned their own paper to self-assess. The 
grade he receives in the self-assessment will be taken into account for the final grade.

After the evaluation between students is completed, the teacher will start the new phase: 
“Grading evaluation phase”.
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Grading evaluation phase
The main objective in this phase is the automatic calculation by the platform of the final 
marks for the submitted work and for the assessment respectively. The teacher can edit 
these notes while in this phase. These notes will be saved in the catalog only when the 
activity is closed in the final phase. Note that it is possible to move between phases even 
after the action has been closed, notes can still be modified directly in the catalog if 
necessary.

Grade calculation method: determines the method of calculating grades for the evaluations 
made. Currently, there is only one option - “Comparison with the best assessment”. This 
option tries to imagine what a hypothetical, absolutely fair valuation would look like.

„Comparison of assessments’: There are 5 options ‘very lax’, ‘lax’, ‘fair’, ‘strict’ and ‘very 
strict’. These options express how strict the rating comparison should be. By “Comparison 
with the best assessment”, all assessments will be compared with the best assessment 
retrieved by the platform. The closer a rating is to the best rating, the higher the rating 
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will be. Specifically, this setting determines how much grades are dropped when ratings 
differ from the best rating. If you are not sure which option to choose, leave the default 
value “fair”.

“Grade for submission”: The final grade for each paper submitted by the learners is 
calculated as the weighted average of the particular evaluation grades given by all assessors 
of that paper. The teacher can influence this grade in two ways: by providing his own 
evaluation, possibly with a higher set weight than the other evaluators; by overwriting the 
note to a fixed value.

“Grade for assessment”: Grade for assessment attempts to estimate the quality of the 
assessments a learner has given to peers. It is calculated by an artificial intelligence 
algorithm of the platform. The platform chooses one of the ratings as the best - the one 
closest to the average of all ratings - and gives it a score of 100%. It then calculates the 
“distance” of all other ratings to this, the best, and gives them lower marks based on 
how different they are from the best rating (given that the best is a consensus of most 
raters) . If there are only two ratings on a job, the platform cannot decide which one is the 
“correct” one. In this case, the teacher can send his own evaluation of the work, or he can 
set a greater weight to the evaluation of the student in whom he has more confidence. 
Note that it is not the final grades of each assessment made by the learners that are 
compared, but rather the scores and feedback of the assessment criteria.

Closing the Workshop activity
When you are satisfied with the final grade, click the icon or text to close the workshop. 
The “Closed” phase will be highlighted and learners will be able to see their notes and a 
conclusion, if you’ve added one.
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8.	 User Groups
Using Context-level Groups
A group or grouping can be used at the level of 2 contexts:

•	 Course level – The group mode defined at the course level is the default mode for all 
activities defined within that course. To be able to use a group, you must set “Group 
mode” in the course settings: Actions Menu > Edit settings > Groups.

•	 Course activity level – Each activity that supports groups can also have its own group 
mode defined. If the course setting “Force group mode” is set to “Yes”, the option to 
define a different group mode for individual activities is not available. If set to “No”, 
then the teacher can change the group mode.

Group Mode
There are 3 group modes:

•	 “No groups” - There are no groups, everyone is part of a community;

•	 “Separate groups” - Each group can see its own group, the others are invisible.

•	 “Visible groups” - Each group works in its own group, but can also see other groups. 
(The other groups’ work is read-only.)

Creating a group
1.	 Within a course, go to the “Participants” section, from where you select Actions Menu 

> Groups > Create Group.

2.	 Give the group a name and optionally a description, registration key, and image.

3.	 Check “Enable group messaging” if you want to enable group-wide conversations.

4.	 Save.

5.	 Select the group to which you want to add participants, then click the “Add/remove 
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users” button.

6.	 From the “Potential members” list, select the users you want to add to the group.

7.	 Click the “Add” button to add users to the group.

Automatic creation of groups
Groups can be created automatically using the button „Auto-create groups” from 
Participants > Actions Menu > Groups. 

General
A naming scheme can be created automatically. “#” is replaced by sequential numbers and 
“@” by letters. For example: Group @ -> Group A, Group B… Group # -> Group 1, Group 2…

Ou can specify: 

•	 An x number of groups

•	 Each group contains x number of members
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Prevent last small group
When you select “Members per group”, depending on the number of users in the course, 
the last group may receive many fewer members than expected. You can select “Prevent 
last small group” to avoid this situation. If the last group will be less than 70% of the 
expected size, then it will not be created. Members left without a group will be assigned 
to those already created.

“Ignore users in groups” must be checked to select only members for the new group, from 
users who are NOT already in a current group.

“Include only active enrollments” gives the option to choose whether to include suspended 
users in groups.

Grouping
„Create in grouping’ and ‘Grouping name’ allows you to create a new grouping and assign 
the new automatically created groups to this grouping. 

A cluster is a collection of groups within a course. Using groupings allows you to direct 
assignments to one or more groups in the course.

Adding groups to groups
1.	 Within a course, access the “Participants” section, from where you select Actions 

Menu > Groups;

2.	 Open the “Groupings” tab;

3.	 If necessary, create a new grouping: “Create grouping”;

4.	 Click on the “Show groups in grouping” icon in the “Edit” column;

5.	 On the “Add/remove groups” page, select the group(s) from the “Potential 
members” list that you want to add to the group;

6.	 Select the “Add” button.
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9. Grades

Existing groupings can be modified and/or deleted using the corresponding icons in the 
“Edit” column of the table on the groupings page.

Assigning grades from the “Assignment” 
activity page
If it is desired to mark some work submitted by learners in the “Assignment” activity (file / 
online text etc.), the best place to enter these notes is in the activity itself.

From the activity page select „View All Submissions”.

On the next page, you will see where you can add notes / feedback and review student 
work. At the top of the page is a drop-down list. Here you have the option to download 
all student work.
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Grader report
All grades of a learner, in a course, can be found in the grade catalog of the course or in the 
“Grader report”. It can be accessed from the block on the left: “Grades”.

To modify notes in the catalog select the button “Turn editing on”, in the upper right corner.

Settings
Course grade settings determine how the grade catalog is displayed to course participants.

This section can be found in Grades > Setup > Course grade settings. 

Grade items
A grade item is a unit (usually an activity) where course participants are graded. “Grade 
item” therefore represents a container for grades and a set of rules applied to those 
grades. Rules affect the calculation and display of grades in reports and catalog exports.

“Grade items” are represented by columns in the grade catalog.

„Grade items” based on activities
A number of activities such as “Assignment”, “Workshop”, “Lesson”, “Quiz” communicate 
their grades to the catalog. The generated grade item can later be modified directly from 
Grades, but then it will be locked within the activity. For example, a teacher who has 
edited in the course catalog a grade for an “Assignment” activity will not be able to change 
that grade in the activity unless they unlock it from the catalog.

List of settings of an activity-based note item „Grade to pass” – Specify the minimum 
grade a learner must obtain to be considered a pass. 
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„Grade type”:

o “None” – Grading is not possible

o “Value” - A numerical value between a minimum and a maximum

o “Scales” - Qualifications

o “Text” - Feedback only „Overall decimal points” This specifies the number of 
decimal places displayed for each note.

•	 “Hidden” - Determines whether this grade item will not be visible to learners

•	 “Hidden until” – A time limit after which the article will no longer be hidden from 
learners

•	 “Locked” – Whether the note item will be locked or not. A locked item no longer 
receives grade and setting changes from the activity

•	 “Locked after” - A date after which the lock will take effect, usually after the date the 
grades are displayed.
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Grade categories
Notes can be organized into note categories. In order for a grade item to be included in a 
category, the “Grade category” field must be set in the respective activity configurations, 
in the “Grade” section, with the desired category.

Adding a grade category: 

1.	 In the “Grades” section select “Setup”

2.	 In the “Grade book setup” section select the “Add category” button

3.	 Give the category a name

4.	 Configure the category settings

5.	 Save
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Editing an existing category:

1.	 In the “Grades” section select “Setup”

2.	 Select the “Edit” icon next to the category you want to edit

3.	 Make the necessary changes and save.

Aggregation of grades
The aggregation field drop-down menu allows you to choose the aggregation strategy 
used to calculate the final grade of a grade category.

Aggregation Strategy
All grades are first converted to percentage values, then aggregated using one of the 
strategies below, and finally converted to the range of grade item values in that category 
(between minimum and maximum).

Mean of grades
Calculates the sum of all grades divided by the total number of grades.

Example: A category A (with maximum mark equal to 100) has 3 articles A1, A2 and A3 
(with maximum marks equal to 100, 80 and 10 respectively); if a student obtains the 
following grades A1=70, A2=20 and A3=10 then the total grade for A will be calculated:

A1 -->70/100=0.7, A2 --> 20/80=0.25, A3 -->10/10=1

A: (0.7 + 0.25 + 1.0)/3 = 0.65 --> 65/100 --> 65 (the maximum grade for A is 100).

Weighted mean
Each grade item can be given a weight to alter its importance in the overall average. In 
simple terms, the total grade of the category will be equal to the sum of the marks of each 
grade item, each multiplied by its weight, and that sum will be divided by the sum of all 
weights.

Example:

A1: 70 out of 100 weight 10, A2: 20 out of 80 weight 5, A3: 10 out of 10 weight 3, category 
A: maximum mark 100

   A1 -->70/100=0.7, A2 --> 20/80=0.25, A3 -->10/10=1

   A: (0.7*10 + 0.25*5 + 1.0*3)/(10 + 5 + 3) = 0.625 --> 62.5/100 --> 62.5 (din 100)
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Simple weighted mean
The difference with the weighted average is that the weight of each item is the maximum 
grade.

Example: 

 A1 --> 70/100, A2 --> 20/80, A3 --> 10/10, max category 100:

 A: (0.7*100 + 0.20*80 + 1.0*10)/(100 + 80 + 10) = 0.505 --> 50.5/100 --> 50.5 (from 100)

„Natural”
This is the sum of all grades, proportioned by their relative weights. The maximum grade 
of the category is the sum of the maximums of all items aggregated.

 A1 70/100, A2 20/80, A3 10/10, without forcing the weights:

 A: (70 + 20 + 10)/ (100 + 80 + 10) --> 100/190

Scores
When grading an activity, it is possible to use a grading scale (grades), a score (numerical 
scale), or neither.

A teacher can select a numerical score for grading by going to the “Edit settings” section of 
an activity, for example “Assignment”, navigating to the “Grade” section and then selecting 
“Point” from the drop-down menu:

This action will open the “Maximum points” field and the teacher can enter the maximum 
score for that activity.

The default number of points a teacher sees when they choose “Point” from the “Type” 
menu, is set by the administrator in Site administration > Grades > General settings.
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10. Tracking progress
„Activity completion”
Activity completion allows the teacher to set completion criteria in the settings of a 
particular activity. A check box appears next to the activity when the learner meets the 
completion criterion. The criteria could be viewing, receiving a certain score, or a learner 
manually marking it as completed.

Depending on the type of activity, there are different completion criteria. For example, 
a page may have the requirement to view; a quiz might have the criterion of receiving a 
grade, while a forum might have the criterion of soliciting posts/discussions/answers.
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„Completion tracking”
•	 Do not indicate activity completion 

•	 Students can manually mark the activity as completed

•	 Show activity as complete when conditions are met.

Require view
When this criterion is activated, students must view the activity, i.e. click on its link to be 
considered completed. You should not enable the “Require view” condition if you have 
other criteria - this clutters the server and it is unlikely that a learner will be able to meet 
any other conditions without viewing the activity.

Require grade
When this criterion is enabled, learners must achieve a grade on the activity to complete 
it. For example, a quiz will be marked complete as soon as the user submits the answers 
(as long as it does not contain essay questions).

It doesn’t matter how well he did with the learner. Achieving any grade will mark the 
activity completed.
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Require passing grade
If a passing grade is set for the test, then the test can be set to be considered complete 
once the learner achieves a passing grade.

If a certain number of attempts are allowed, the test can be completed once the learner 
has taken them all (even if, for example, they did not achieve a passing grade).

Note that “Require grade” must be set as well as “Require passing grade”.

Lesson Completion Settings
The following conditions are specific to the “Lesson” activity (in addition to the standard 
ones):

„Require end reached”: For the lesson to be marked complete, the learner must 
reach the last page of the lesson. 

„Require time spent”: For the lesson to be completed, the learner must spend a 
teacher-specified amount of time on the lesson pages under this condition. If they finish 
the lesson early, they will receive an alert saying that they have not reached the minimum 
acceptable time and should repeat the lesson.
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Assignment Completion Settings 
„Student must submit to this activity to complete it”
This condition means that an “Assignment” activity can be considered complete once the 
learner has submitted it.

“Forum” activity completion settings 
„Require posts”
In order for the forum to be marked as “completed”, the learner must start a discussion 
or reply to a discussion. In the box can be specified the total number of posts they have 
to make. 

„Require discussions”
The learner must start a discussion topic. In the box you can specify the number of posts 
to make. Note: This condition cannot be met using Single simple discussion or Q and A 
forums, as learners cannot create discussions in either type. 

„Require replies”
The learner must respond to a discussion. In the box you can specify the number of posts 
to make.

„Expect completed on”
When a date is entered here for a Forum activity or resource, Page or Folder, the expected 
completion date will be displayed on the new course presentation block.
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 „Course completion”
 „Enabling Course completion”
An administrator can enable “Course completion” on the platform by selecting “Enable 
completion tracking” from Site administration > Advanced features.

A teacher can then enable “Course completion” for their course by setting “Enable 
completion tracking” to “Yes” in the course settings edit page. (Actions Menu > Edit settings 
> Completion tracking > [expand the category] > Yes > Save and display)

A course completion link will appear in the “Actions Menu” at the top right. Clicking on it 
will bring up three tabs:

Course completion settings
General
Choose how you want to mark course completion – whether you want some “Any” or all 
“All” conditions to count towards course completion.

Condition: Activity completion
Check the boxes of the activities you want to count towards course completion.
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Condition: Completion of other courses

This setting allows you to make the completion of another course a condition for the 
completion of the course you are currently working on. This does not block the learner 
from the current course; it simply means that the current course will not be fully marked 
until the first course has been fully marked. Thus, completion of the current course is 
dependent on completion of a previous course. Select one or more courses in the field 
„Courses available box”.

Note: To remove a course from the list if it is no longer needed, press CTRL+click on the 
highlighted course and it will be disabled.

Condition: Date
You can set a date after which the course will be completed.

Condition: Enrolment duration
You can choose a number of days after registration in which the course will be completed.

Condition: Un-enrollment
The course will be marked complete after the learner is deactivated from the course.

Condition: Course grade
You can set a passing grade for the course.

Condition: Manual self-completion
If this criterion is enabled, a learner can self-mark the completed course from the “Self 
completion” block.



Condition: Manual completion by others
Users with certain roles can mark the course as completed if their role is checked here. 
“ALL” means that each role must mark the completed course; “ANY” means it will be 
marked complete after one of the roles checked here has marked it.
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II. OFFLINE ASSESSMENT 
PLATFORM - BBS EXAMINER 

USER GUIDE
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1. Introduction
What is BBS
BBS is an application that allows the automatic examination of pupils / students, using grid 
type tests with only one possible correct answer. The application allows the creation of 
possible variants (maximum 9) of topics, in which the same set of questions and answers 
is used, but in random order.

What is NOT BBS?
BBS is not a candidate registration management application, or an electronic catalog. 
Although the history of examinations can be kept, the purpose of the BBS is not to 
replace the method of recording and archiving candidates’ grades. Therefore, it is not 
recommended to keep the marks / scores / status of the candidates within the platform.

Abbreviations
Abr. Term Abr. Term
- - - -

Known issues and limitations
There are currently no known issues or limitations within the platform. The section will be 
updated over time.
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2. Types of Users

Currently, the platform defines three types of users: Administrator, Examiner and 
Candidate, each with well-established roles, mapping as closely as possible the physical 
roles of people in the real environment.

Role mapping in real environment can be understood as:

The role in the platform The real role
Pre-university education University 

education
Administrator IT Technician, IT Infrastructure 

Manager, Institution Manager
IT Technician, IT 
Infrastructure 
Manager, IT 
Department 
Manager

Examiner Professor Assisi. Univ., 
Conf. Univ., Prof. 
Univ.

Candidate Student, Admission Candidate Student, 
Admission 
Candidate

Administrator user type
The administrators of the platform are the staff of the IT department of the school unit (in 
case of installation in the premises of the unit), in charge of proper installation, verification 
of functionality and definition of users within the platform (other administrators and 
examiners). Administrators have the same rights as Examiners, plus the ability to define / 
add users.

Examiner user type
The examiner is the person, employed in the school, with the necessary skills to 

define questions and the rights to give grades to candidates. Examiners have access to the 
application administration interface, with the following rights:

1. Defining and modifying the categories of questions that will be used to generate 
exams;

2. Defining and modifying the questions that will be used to generate exams;

3. Uploading, adding, modifying and deleting candidates in the platform database;

4. Creation, modification, administration of examinations;
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5. Marking, eliminating wrong questions in an examination;

6. Introducing candidates to the platform.

User type Candidate
The candidate is the user who benefits from the educational process and who has 

the obligation to take the exams required by the examiner. Candidates do not have the 
opportunity to enter / modify any information within the platform, but they can view their 
exam results as well as the exam history.

Platform authentication of the candidate to verify the 
score obtained

Candidates can authenticate on the platform using the address / portal / login (the 
address is relative to the application installation location).

Figure 1 Candidate authentication window (to see the scores obtained)

Entering the contest code is done using the numeric keys.

After logging in, the candidate will be able to see all their exams: 

Attention! For security reasons, the paper will not be displayed to the candidate if 
competition codes are incorrect.
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Adding / modifying a candidate
In the Candidates section, you can enter a candidate manually by using the Add button.

Figure 2 Candidate add button and other operations available to candidates

After pressing this button, the candidate add window opens: 

Figure 3 Add / edit window of a candidate in the platform

Field explanation:

• Name and surname: refers to the full name and surname of the candidate;

• Grouping: The right grouping criterion (eg school year);

• Competition code: the internal competition code used in the school. If this code 
does not exist, a unique random code can be generated by clicking on that field. 
The code must be a fixed 8 numeric characters.

The Save button will validate and save the candidate.
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Grouping of candidates
The platform offers the possibility to group candidates according to different 

criteria (eg year of study). The implementation of the functionality is a flexible one, any 
text can be used as a grouping criterion. The condition of the grouping is that all candidates 
have the exact same text defined in the grouping.

For ease of manual entry of candidates, it is possible to choose a previously used 
grouping criterion. The application will suggest grouping criteria as characters are entered 
in that field.

Figure 4 Selecting a pre-existing category for a particular group of candidates

Clicking on the desired value will replace the existing text in this field.

3. Examination
Whether we are talking about a semester test, a thesis, or an exam (completion or 

admission), all these forms of examination are found in the form of examinations within 
the platform. All of these forms involve offering a grid-type test with a number of questions 
(from one or more categories, as appropriate). The examination flow is designed to be 
flexible, being able to adapt to a large extent (though probably not 100% to any situation) 
to as many internally defined examination processes (methodologies).

Examination flow
The examination flow is divided into three major components:

1. Defining and introducing categories of questions and questions;

2. Introduction of candidates (students working inside the school), grouped 
according to certain criteria;

3. Defining and sustaining examinations.

These components can all be followed, but also in turn, the only requirement being 
that when defining / creating an examination, the necessary candidates and questions be 
introduced and validated.
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Figure 5 visually defines the normal input / validation / generation sequence 
required to successfully complete a platform scan.

Figure 5 Complete examination flow of candidates

As you can see, there are several ways to use the platform, from which we propose:

• The complete mode, in which the database is completely empty and the steps 
must be taken from the beginning to the end. In this way, categories of questions, 
related questions and answers, as well as the list / lists of candidates must be 
added, all these steps being mandatory before starting the definition and taking 
of the examination;

• The short variant of the flow presupposes the existence of the candidates in the 
database, as well as the questions / categories of questions. The work therefore 
begins with the definition and support of the examination;

• The hybrid variant involves the addition / modification (as appropriate) of some 
questions and / or candidates, continuing with the definition and support of the 
examination.
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4. Defining questions, types of questions 
and answers

For easier administration, the questions are grouped into categories (for example, 
a subject can be a category, or each school / student year can be a category for a particular 
subject, such as “Mathematics XI”). Each category can contain several questions, but one 
question can have only one category (relation 1 - N).

Defining a category of questions
Defining a category is done in the Question Categories section by clicking the Add 

button at the top of the page.

Figure 6 Available operations for question categories

Fill in the category name and click the Save button:

 

Figure 7 Add a category of questions window

If you want to change the category name, select it with the selection box to the 
left of the desired category and press the Edit button:
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Figure 8 How to edit a platform entry

Change the name to the one you want and press the Save button.

Defining a question
Similar to the categories, the questions are added to the Questions section of the 

platform by choosing the Add button: 

Figure 9 Operations available for questions

The questions have two required fields, namely the statement of the question and 
the category to which it belongs: 

Figure 10 Question window

The statement of the question can be customized according to needs, by using 
formatting functions (Bold, Italic, and Underline). Special characters can be entered using 
the Ω button at the top right of the editor. You can also enter complex mathematical 
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formulas, either using the LaTex language (see Figure 11) or with the help of the internal 
editor (see Figure 12).

Figura 1 On this page you can enter LaTeX code for formulas

Figure 12 Internal (visual) formula editor

Also the formulas can also be included in the question statement.

After defining the statement, click the Save button to save the question to the database.

Attention! The question is saved only after pressing the button! Closing this window will 
undo any changes made to this window!

Defining the answers to a question
Once you have defined the question, you can define answers to it. Select the question you 
want and choose the Answers button at the top of the page:

Figure 13 How to edit a question
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The answer management window will open:

Figure 14 Answer management window for a selected question

Here you can add new answers, using the Add option, you can edit the entered 
answers, using the Edit button (after selecting an answer, the buttons are activated 
automatically).

Attention! In order for an exam to be generated, there must be at least the 
number of answers to each defined question as in the definition of the exam (If we define 
a 4-answer exam for each question and the question has only 3 answers defined, the 
application will give an error).

Each question can have only one correct answer.

Similar to questions, mathematical and / or chemical formulas can be used in the 
answers, the editor being similar. At the bottom of the window (see Figure 15), check 
Is the correct answer will check if the current answer is correct. Marking an answer as 
correct will remove the previous correct answer.

Figure 15 Window for defining an answer to a question

If the question does not have a correctly defined answer, the application will give 
an error when generating an examination.

The verification of the questions can also be done through the Validate the questions 
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button (functionality in progress), which will check the existence of answers to each 
question, as well as the correctly defined answer to each one. 

5. Defining an examination

Each examination consists of two documents (two sheets), namely:

• The sheet containing the questions and answer options (topic). This sheet is 
not written and remains with the candidate or is handed in at the end of the 
examination (as the case may be, according to the rules established internally by 
each educational unit);

• The sheet that will contain the candidate’s answers. This sheet will be dated 
and will contain the candidate’s name, signature and other required fields, along 
with his answers to the examination questions.

Examples of the two sheets can be seen in Figure 16.

	

Figure 16 Template for the answer sheet and the question sheet (topic) coming to the candidates

Each exam has the following required fields, which are entered in the form to add 
a new exam:
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• General settings for review:

o Exam name: how you want this exam to be called. This field will also be 
visible to candidates;

o Number of questions: how many questions will the exam have in total;

o Number of answers: how many possible answers will each question 
have;

o Number of variants: several variants will have the examination;

o Evaluation test generated by the platform:

	will allow the automatic generation of variants with 
questions from the database;

	 It will NOT allow only the generation of an examination 
sheet, without entering the questions in the database;

• Exam sheet settings (candidate answer sheet):

o Number of columns: how many columns the questions will be divided 
into (set in the general settings);

o Answer sheet header: The content (information and fields) required for 
the answer sheet header (such as examination date, year, group, etc.);

o Answer sheet footer: The content (information and fields) required for 
the answer sheet footer (such as signatures)

• Question sheet settings (student question sheet):

o Number of test display columns: how many columns the questions will 
be displayed on the sheet received by the candidates. If the questions are 
short, they can be displayed in two columns for space saving;

o Align test answers:

	Horizontal alignment: answer options will be displayed on 
a single line (if possible). This option is suitable for short 
/ simple answers.

	 Vertical alignment: the answer options will be displayed 
vertically, one below the other. This variant is suitable for 
long / complex answers, or containing mathematical / 
chemical formulas;

Creating the exam
Creating an exam is done by clicking on the Add button, which can be found in the Exams 
category:
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 Figure 17 Locating the exam creation button

In the creation window, enter the data of this examination, as they are presented 
in the previous section. After completing the data, click the Save button.

Figure 18 Examination Addition Window

The options / actions available for review are displayed as the review progresses 
(see Figure 19). Thus, for newly created exams, the available options are:

Figure 19 Options available for new exams

Defining the categories of questions and the questions that will exist on the exam 
is done by choosing the Question Categories option. Clicking on this button opens the 
following page:

Figure 20 Configuration page (addition, modification) of the categories of questions and questions on the exam
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Add question categories and questions
The order of the categories on an examination can be determined by adding in the 

correct order the categories. On each variant generated, the categories will have the same 
order, but the questions will be mixed within a category.

For each category added on the exam, we need 3 parameters:

• The chosen category;

• Test order number;

• The number of questions that will be included in the exam in the current category.

Figure 21 Window for adding a category to the current preview

At the end, we will have the categories defined on the exam:

Figure 22 Categories selected from an examination, with actions available to them

Adding exam questions
Adding exam questions can be done in two ways: automatically and manually. 

The automatic variant will choose completely randomly the set number of questions from 
each category added on the exam. This option can also be chosen if we only want to 
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complete the questions (ie we have chosen a few manually and we want the automatic 
completion up to the set number).

If you choose the manual option (click on the +/- Questions button), the examiner 
will choose one by one the questions that he wants to be added on the exam:

Figure 23 Questions Add Window

Selecting a question will automatically add it to the list of selected questions. At 
the top there is a total of the number of selected questions as well as the necessary ones, 
as defined in the previous step, to know how many more questions need to be selected 
from the current category:

Figure 24 Summarize the number of questions selected and the number of questions required on the current 
examination

Once the questions have been completed, the auto-fill option from the categories 
will disappear, and the exam can be generated:
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Figure 25 Display of related categories and options once the questions have been completely added

Generation of examination variants
Once the questions have been completed, the examination options can be 

generated. They will have the same set of questions, but in a different order. The answer 
options will also be in a different order. To do this, use the Shuffle button:

Figure 26 Positioning the examination variant generation button

After clicking this button, the confirmation window will appear. It is worth noting 
that once these tests are generated, they can be regenerated.

Careful! However, if the examination has been performed and tests have been 
uploaded for grading, the regeneration will remove these grades from the database, as in 
this case the examinations are no longer relevant!

Figure 27 Confirmation window for generating variants

After generating variants, new options appear on the review:
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Figure 28 New options after generating variants

Thus, we can download the PDF files related to the answer sheet but also the 
variants of topics.

Download PDF files, their location
The answer sheet is downloaded via the Exam button, available for review:

Figure 29 Locating the answer sheet download option and the Template button

Topics can be downloaded by clicking on the + Subjects. The exam options page 
(templates) will open:

Figure 30 Examination page (templates)

Physical examination
Physical examination involves printing previously printed PDF files. Each candidate 

must receive an answer sheet (examination sheet with the candidate’s answers) and 
one of the options. These variants are established by the internal methodology of the 
educational unit.

Upon completion of the examination, the answer sheets should be centralized, 
scanned and uploaded to the platform.

Before uploading the PDF files to the platform, the link must be made between 
the answer sheet (QR code of the answer sheet), the candidate’s competition ID (QR code 
of the candidate’s competition ID) and the witness’s competition code (QR code of the 
witness’s competition ID) by using a QR code reader, using the Links button -> Add button.
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Scan and upload files to the scoring platform
The answer sheets are scanned after they are centralized. The scanner used must 

be of a good quality, with no optical line defects, as they may lead to false lines on the 
scan, areas of no contrast, or other problems that interfere with the detection process.

The scan can be done in either color or black and white. Instead, the scan resolution 
should be between 200 and 300 dpi. Resolutions lower than 200 will make it impossible to 
detect, and higher than 300 will slow down the process, generating files that are too large. 
The scan format must be PDF.

Scanning can also be done on sets of works (so it is not necessary that they are 
all in the same scanned file). The resulting files are uploaded to the platform using the 
Marking button.

After loading, the platform will start the detection process, which, depending on 
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the number of tests and their complexity, may take several tens of seconds. At the end of 
the process, the Submissions button will appear on the interface:

Figure 31 Locating the Corrected button to view a preview

View results for a review after correction
After correcting the works, the Submissions button is activated. By clicking on this 

button, you can see the window

Figure 32 Corrected jobs window

From this window you can see the works of this examination, the score obtained 
by each and the marks calculated for these scores (with or without a point ex officio). If 
the test encountered an error, the error text will be displayed in the corresponding field.

The job list can be downloaded in Excel or CSV format. You can also see the papers 
by clicking on the View button, where the candidate’s answers will be marked and whether 
they were correct or not:
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Figure 33 A job view window

At the bottom of this window, you can also see the actual scans of the paper, along 
with the detected answers, so that you can visually estimate the correctness of the scan.

Wrong questions, giving maximum score for these 
questions

In some situations (due to external factors / human error), some questions may 
be wrongly defined. In this situation, most methodologies involve giving the score for that 
question to all candidates. This functionality is accessible via the Wrong Questions button, 
a button available on each configured exam (see Figure 34).

 Figure 34 Positioning the Wrong Questions button

Pressing this button will open the interface for defining the wrong questions:

Figure 35 Wrong question page
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Any number of questions can be defined for a particular exam.

Attention! Marking a question as wrong is done on each exam! Marking on a 
certain exam will not recalculate the grades on other exams!

Defining a question as wrong (or marking) is done using the Add button. Pressing 
it will open the question selection window:

 Figure 36 Wrong question setup window (for which candidates receive maximum score)

Only the questions on the current test (with all the generated variants of it) are 
displayed in this window. After choosing the question, press the Add button, at which 
point the platform will make the following changes:

1. All loaded tests shall be checked and if the candidate did not choose the correct 
answer, he / she will be given a score for this question;

2. If the candidate has chosen the correct answer, the candidate already has the 
respective score, so the platform will not make changes;

3. This operation is saved in the database so that it can be canceled and viewed 
later.

If the question proves to be correct, the wrong question mark, as well as the points 
awarded for this question to the candidates, can be withdrawn by choosing the Remove 
button for that question.

6. Reports
Examiners can generate reports for completed exams on the home page. From the top of 
the page, three parameters are chosen:

• Desired examination;

• The variant for which you want statistics;

• Desired chart type.
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The platform will upload data to the page:

Figure 37 Bar Chart generated for an exam

The resulting graphic can be saved by right-clicking on the image and Saving the Image.

Figure 38 Right-click menu to save an image (Firefox browser on Windows)

The resulting image can be used in any activity report, by inserting it in the document, in 
the desired place.
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7. Good practices for taking a physical 
exam

It is very important to know and follow these good practices, so as to ensure that 
the platform has all the necessary conditions for proper operation.

Define questions correctly and retrieve them from 
Word files

•	 Avoid retrieving text from questions in Word files, as they define text 
dimensions as well as other settings that the platform tries to keep. If you still 
need to enter text from other sources, use the Paste Special feature (available 
on any operating system), with the shortcut Ctrl + Shift + V, or, depending on 
the browser used, the Paste Special button:

Figure 39 Locating the Paste Special button within the interface

•	 Avoid complex formatting with different text sizes and / or changing the fonts 
used. The complexity of the formatting will make the text difficult to follow 
and the tests will not have unity.
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Correct definition of header and footer for 
examination sheets

•	 Avoid header and footer tables. The lines (borders) of the tables can interfere 
with the detection process, leading to errors;

•	 For signature areas, leave enough space for signatures not to overlap with the 
detection area.

Printing examination sheets
•	 It is important that the exam papers are printed on A4 paper at 100% size 

(without scaling). Scaling changes the size of the detection area and can lead 
to problems in recognizing and validating them;

•	 It is also important to insert the correct paper into the printer as well as centre 
the paper correctly so that the printed text is framed correctly (not tilted on 
the page).

Correct completion of examination sheets by 
candidates

•	 The correct filling of the circles (their correct filling) supposes the filling of 
the desired circles as close as possible to 100%, without exceeding the limits 
of the circle and without leaving empty spaces. The ink / ink used must be 
dark in color (black, blue) and the use of pencils is not ecommended, as the 
contrast provided by the pencil lead is not sufficient.

40 Types of correct and incorrect completion of tests

Correct scanning of examination sheets completed by 
candidates

•	 Scan resolution of at least 200dpi

•	 Use quality scanners without scratches and streaks or dust on the glass
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•	 Correct positioning of the sheets in the scanner to ensure a straight, straight edge 
(undistorted) scan.

8.	 Potential problems, avoiding and / 
or solving them

Problem Potential cause Solution
Detection does not 
work properly

Poor scan quality - Use a quality scanner, make sure the 
scanning surface is clean, and the scanner is 
free of defects.

- Make sure the scanner picks up the sheets 
correctly (guides guide the sheets to be 
scanned correctly);

- Make sure you scan at 200dpi and enough 
contrast;

Poor print quality - Make sure the printer has enough toner / 
ink for quality, uninterrupted printing.

- Make sure you have printed the sheets at 
100% scaling factor;

- The printout should not contain 
improperly printed dots, lines, or areas (for 
example, when the laser printer drum needs 
to be changed).

Questions do not 
look good, text 
sizes / colors / fonts 
are different

Using text copied 
directly from 
Word (or other 
formatted files), 
lacking a standard 
or unit-approved 
format

- Do not use Copy / Paste directly. Use the 
Paste Special feature to remove formatting;

- Use the same formatting style for all 
texts. The formatting style should be 
established from the beginning of the use 
of the software and closely followed by all 
those who introduce / define questions and 
answers;
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The candidate 
cannot see his 
work, even if it has 
been uploaded

The contest code 
is incorrect on the 
work

The works are displayed ONLY if the 
competition code is correct on the work;

- Make sure these two codes are correct 
(the examiner can see all the papers);

- If all is correct and the candidate still does 
not have access, contact the application 
administrator.




